cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lilySixteen
Frequent Visitor

Remove strings from MS Form attachment links

Hi Community!

 

I'm building a flow to send MS Form responses to emails. Users need to be able to review Form responses from the email alert and click on the link to view images attached to the MS Forms. Everything works fine except for the attachment links. Below screenshot is what it looks like in the body of the email alert. How to remove the highlighted strings (should be OneDrive nomenclature) and only keep the hyperlink to make it look clean?  Appreciate your help!

 

lilySixteen_0-1656081721858.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-xiaochen-msft
Community Support
Community Support

Hi @lilySixteen ,

 

I did a sample for you.

vxiaochenmsft_0-1656311661790.png

vxiaochenmsft_1-1656311698117.png

json(outputs('Get_response_details')?['body/<id>'])?[0]?['link']

 

Best Regards,

Wearsky

View solution in original post

7 REPLIES 7
v-xiaochen-msft
Community Support
Community Support

Hi @lilySixteen ,

 

I did a sample for you.

vxiaochenmsft_0-1656311661790.png

vxiaochenmsft_1-1656311698117.png

json(outputs('Get_response_details')?['body/<id>'])?[0]?['link']

 

Best Regards,

Wearsky

Hi @v-xiaochen-msft ,

 

Thanks so much for the answer. I have tested it with the expression that you provided, but when I receive the email notification, the strings still appear along with the attachment link. Is there a different way that I can try? Thanks!

v-xiaochen-msft
Community Support
Community Support

Hi @lilySixteen ,

 

I don't know why it doesn't work. Please share some screenshots.

 

Best Regards,

Wearsky

lilySixteen
Frequent Visitor

@v-xiaochen-msft Please see below. This is the flow that I tested but the link to the attachment in the email notification still contains unnecessary strings as highlighted in the 2nd screenshot. Can you please take a look and let me know how to fix it? Thanks!

 

lilySixteen_0-1656620285164.png

 

lilySixteen_1-1656620397779.png

 

 

v-xiaochen-msft
Community Support
Community Support

Hi  @lilySixteen ,

 

You are close to the answer. Just use the compose outputs instead of the form dynamic content.

vxiaochenmsft_0-1656638904731.png

 

Best Regards,

Wearsky

@v-xiaochen-msft You rock Wearsky! Thanks so much for the answer!!

lilySixteen
Frequent Visitor

@v-xiaochen-msft It worked in one flow, but when I use the same compose action (with your json function) in another flow, it shows the below error message. Any idea? Appreciate your insight!

lilySixteen_0-1656677601343.png

 

Here is the flow. It's exactly the same as the one I posted earlier...

lilySixteen_1-1656677693913.png

 

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (3,428)