cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jasonmurphy
Helper I
Helper I

Removing unwanted character output from MS Forms

Hi All,

 

I've found some solutions on this forum to replace unwanted characters from MS Forms, but am not getting far with removing the \n characters that get appended to multiple choice responses in MS Forms.

 

Here are some of the other posts that have helped me reach this point:

 

Here is a picture of my flow:

Screen Shot 2021-11-25 at 9.51.52 am.png

 

The compose function is using this expression:

 

 

 

replace(body('Get_response_details')?['re161b12e16c941ba887a822bf85f74d3'],'\n','')

 

 

 

 

I have also tried using the expression directly within the SharePoint update list item connector. In all cases, the replace function is simply ignored and the output is:

 

"Option1\n"

"Option2\n"

Etc...

 

This is a real dealbreaker because the data is being inserted into a SharePoint List calculated column and results in a line break, which breaks the calculated column formula.

 

Any help would be greatly appreciated.

 

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
fchopo
Super User
Super User

Hi @jasonmurphy 

Could you try this?:

uriComponentToString(replace(uriComponent(body('Get_response_details')?['re161b12e16c941ba887a822bf85f74d3']), '%0A', ''))

The UriComponent function returns an uncoded version for a string and replace unsafe characters with escape characters ('%0A' is line break one). The UriComponentToString encodes again the string.

 

Hope it helps!

Ferran

 

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

View solution in original post

2 REPLIES 2
fchopo
Super User
Super User

Hi @jasonmurphy 

Could you try this?:

uriComponentToString(replace(uriComponent(body('Get_response_details')?['re161b12e16c941ba887a822bf85f74d3']), '%0A', ''))

The UriComponent function returns an uncoded version for a string and replace unsafe characters with escape characters ('%0A' is line break one). The UriComponentToString encodes again the string.

 

Hope it helps!

Ferran

 

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!

View solution in original post

jasonmurphy
Helper I
Helper I

Thank you @fchopo. It worked! Really appreciate it. 🙂

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Top Solution Authors
Top Kudoed Authors
Users online (2,092)