cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JimF0
Helper I
Helper I

Rename a Folder through Flows

Hi All,

 

I have read through all of the other threads and even some online articles regarding this subject, but I was hoping someone may be able to shed a little light into my issue.

 

I have a test flow set up as per all the tutorials on the Send HTTP request connection, yet no matter how much I try the flow always just out puts the below {"d": {"ListItemAllFields"null}}, it's as if the folder been selected doesn't have any information for the flow to use!

JimF0_0-1622808009303.png

JimF0_1-1622808046147.png

 

 

Thanks,

Jim



1 ACCEPTED SOLUTION

Accepted Solutions
annajhaveri
Community Champion
Community Champion

@JimF0  Change the header value Accept to "application/json;odata=nometadata" and add Content-Type header with same value "application/json;odata=nometadata", as shown in screenshot below. 

annajhaveri_0-1622810381519.png

 

 

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.

View solution in original post

3 REPLIES 3
annajhaveri
Community Champion
Community Champion

@JimF0  Change the header value Accept to "application/json;odata=nometadata" and add Content-Type header with same value "application/json;odata=nometadata", as shown in screenshot below. 

annajhaveri_0-1622810381519.png

 

 

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.

Thank you for the suggestion, i've included this in my flow but still no luck we now get the out put: 

JimF0_0-1622812573711.png


I've tried using a static folder instead of my variables, i've tried replacing the ' with " and vise versa in the body. Yet the same result happens.

JimF0_1-1622812714758.png

 



Working! Apologies, I found my own error in the api "_api/web/GetFolderByServerRelativeUrl('Shared Documents/Documents/General/Colleague Training SignOffs/1. Archive/999999')/ListItemAllFields" shouldnt have included the Documents!

Should have read "_api/web/GetFolderByServerRelativeUrl('Shared Documents/General/Colleague Training SignOffs/1. Archive/999999')/ListItemAllFields"

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (6,569)