cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Gochix
Resolver I
Resolver I

Reply to teams message doesn't fetch message id..

Good evening,

Trying to send a reply to teams message but flow can't fetch message id..

I tried to find post a reply to teams V2 but for some reason it wont show up in my list so i'm using reply with a message in a channel..

Flow:

 

Gochix_0-1633453882770.png

In filter array where contains - i have just input from powerapps which is :  PostReplyTeams.Run("ID:55") - ID:55 contains message that i would like to reply with Completed.. In run history flow shows up as completed without any error but haven't got a reply to message in teams..

 

Gochix_1-1633454233518.png

 

Message in teams :

Gochix_1-1633454362297.png

 

Am i doing something wrong here?

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @ekarim2020 ,

For some reason flow shows that there is no body outputs..

 

Gochix_0-1634016977864.png

 

Can the issue be just that it fails to fetch what input value i'm telling flow to fetch?

 

Gochix_1-1634017064846.png

 

In powerapps i just say to flow to look on message that contains #59 and in teams i actually have #59 in message.. so i don't know..

 

EDIT: I've fixed this by changing in Filter array from Message body to Message body content. 

Thanks for pushing me to sort it out 😉 

View solution in original post

2 REPLIES 2
ekarim2020
Super User
Super User

What does the run history of the filter array action show? Is the filter returning any data?

ekarim2020_0-1633772723570.png

2021-10-09_10-46-19.jpg


Ellis


____________________________________
If I have answered your question, please mark the post as Solved.
If you like my response, please give it a Thumbs Up.

 

Hi @ekarim2020 ,

For some reason flow shows that there is no body outputs..

 

Gochix_0-1634016977864.png

 

Can the issue be just that it fails to fetch what input value i'm telling flow to fetch?

 

Gochix_1-1634017064846.png

 

In powerapps i just say to flow to look on message that contains #59 and in teams i actually have #59 in message.. so i don't know..

 

EDIT: I've fixed this by changing in Filter array from Message body to Message body content. 

Thanks for pushing me to sort it out 😉 

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Users online (2,171)