cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Ben_Love
Level: Powered On

Request intermittently stops receiving callbacks

We have an in-house app (Connectwise) that I am trying to hook into Flow. I know that callbacks generated by our app are working, as testing to other services (Zapier, Mockbin) all succeed. When I create a new Request connection in Flow however it does not receive my callbacks. Testing to the new Request connection using Postman DO succeed. 

 

Last time I created a new Request connection for this, it magically started working after I had not touched it for a few hours. 

 

Obviously an odd problem. Can anyone offer any thoughts on what's going on here? 

1 ACCEPTED SOLUTION

Accepted Solutions
Ben_Love
Level: Powered On

Re: Request intermittently stops receiving callbacks

Update on this. Turns out there were some undocumented 'features' in the application sending the webhooks that was causing this issue. 

View solution in original post

3 REPLIES 3
Community Support Team
Community Support Team

Re: Request intermittently stops receiving callbacks

Hi @Ben_Love,

 

Can you share the detailed configuration about your flow? Also, did you get any error message when you have the issue?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Ben_Love
Level: Powered On

Re: Request intermittently stops receiving callbacks

Hi Mona,

 

At this point in my testing the flow itself is super simple. It simply has a single Request item to catch the callback I'm throwing from our app, and then a single Slack action to post a generic message on a slack channel saying the callback was received. There is nothing appearing in the Flow History. 

2017-06-24_10-04-47.jpg

Request URL: https://prod-26.australiasoutheast.logic.azure.com:443/workflows/bd45222672ad4ac2a38aa8f472b61eb7/tr...

 

Screenshot attached of the entire flow. 

 

 

Ben_Love
Level: Powered On

Re: Request intermittently stops receiving callbacks

Update on this. Turns out there were some undocumented 'features' in the application sending the webhooks that was causing this issue. 

View solution in original post

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors
Users online (4,913)