cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper II
Helper II

Responses Aproval Condition control always fails

Hi All,I have a flow with approval request, when triggered the approval request action works, but fails when I try to check a condition if(responses == Approve), even when I approve the request. i'm I doing this wrongly ? Pls see the image below :capture.png

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

@Mhak I found the problem, use outcome in your condition and make sure whoever gets the Approval request is the owner of the records that needs Approval or Rejection. If they arent the owner, it throws an error. I hope this solves your long existing problem with Approval.

View solution in original post

11 REPLIES 11
Dual Super User II
Dual Super User II

Hi @onyebuchiboss 

 

Use the Outcome dynamic output and compare it with Approve 

 

Regards,

Reza Dorrani

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

This I find does not work all the time. Not sure why... 

Dual Super User II
Dual Super User II

Hi

When it does not work can you check the flow run for the error message in that case

If you put Outcome, it will say no subsequent action after the condition, and it will fail.  

 

If you put Responses, it will say false even if you click Approve on a condition Responses is equal to Approve

@RezaDorrani  and @Mhak its saying "no subsequent action after the condition ". How can I get past this.

I am on exactly the same boat. It worked for me yesterday then today, it started failing. 

 

Not sure if it is a bug or an updated feature without any documentation yet. 

 

Previously, I used Response on all my approvals. Now they just messed it up a bit...I don't quite get the difference between start and wait for an approval, create an approval and wait for an approval and why they have different dynamic content. 

 

HELP!!!

 

 

@RezaDorrani @Mhak I did a microsoft demo approval a while a go, I used "Response" and not "Responses", and that one worked. How can I generate "Response" and not "Responses" (without the S). Like the below image, I have followed all stepped strictly, but still generate the one with an response instead of Response(s).capture.png

Helper II
Helper II

@v-yamao-msft please look at this, you might know somethignwe dont. cheers.

 

Hi @onyebuchiboss ,

 

Basically, we are now using the Outcome to determine the approval result, and Response has now been removed.

Responses contain all the details of the approval and will be output as an array.

Please refer to this similar thread and see if it helps:

https://powerusers.microsoft.com/t5/Building-Flows/Response-Dynamic-Content-for-Approvals-does-not-a...

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@Mhak I found the problem, use outcome in your condition and make sure whoever gets the Approval request is the owner of the records that needs Approval or Rejection. If they arent the owner, it throws an error. I hope this solves your long existing problem with Approval.

View solution in original post

Anonymous
Not applicable

@RezaDorrani  Your answer is correct, but what if I have multiple approval sections. Do I have to make several conditions? Because I found that when I use outcome it is specific for a single approval section, not all the sections.

 

How can walkaround this issue?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (11,086)