cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mcastine
Helper I
Helper I

Role Security

Advanced | Flow of The Week: Role Based Security in PowerApps using Flow & SharePoint Groups I have followed the above tutorial and the response in one of the columns but the system returns everything as true. For some reason, it is not seeing that the results [] is the same as the condition []. Has there been changes made again that makes this tutorial not work properly? When a user is NOT in the SharePoint group, it gives this code, which is correct {   "d": {     "results": []   } } Then the compose is set to value: [] But the condition still says "true". But should be false. I can't get it to say "false".

1 ACCEPTED SOLUTION

Accepted Solutions
mcastine
Helper I
Helper I

I finally found another walkthrough that actually worked. The condition was set to "does not equal" value "true". Not adding the [] which is in multiple walkthroughs and doesn't work. 

View solution in original post

6 REPLIES 6
Brad_Groux
Community Champion
Community Champion

If you could provide an expanded screenshot of your Flow and steps, your Flow run history, and of any detailed error messages you're receiving we could likely better assist you. Also, for the best results, you may want to review How to write a good forum post.

If this reply answers your question or solves your issue, please ACCEPT AS SOLUTION ☑️. If you find this reply helpful, please consider giving it a LIKE. Want to know more? Follow @BradGroux on Twitter, and check out my Medium blog at https://msft.engineer.

 

mcastine
Helper I
Helper I

It actually changed my post when i submitted it. I had screenshots and links but it took it all out. I can't seem to get it to take any images. 

Has there been changes made again that makes this tutorial not work properly?

I have followed the above tutorial (and the response in one of the comments) but the system returns everything as true. For some reason, it is not seeing that the results [] is the same as the condition [].

When a user is NOT in the SharePoint group, it gives this code, which is correct

{   "d": {     "results": []   } }

Then the compose is set to value: []

And a condition is created to compare the two (UserGroupInfo) with the Compose value ([])

The condition when it is run says "true". But should be false since the user is NOT in the group. 

Hello @mcastine 

 

Please use the add photo button to add pictures. Sometimes copy and pasting the image / ImageURL does not work.

 

We will need to see your flow in order to help you.


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





mcastine
Helper I
Helper I

https://i.postimg.cc/xjpQKmPP/2020-11-10-13-50-19.png <-- here is the link. It will not let me add it through the camera. It deletes it. 

mcastine
Helper I
Helper I

I finally found another walkthrough that actually worked. The condition was set to "does not equal" value "true". Not adding the [] which is in multiple walkthroughs and doesn't work. 

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

New Process Advisor Capabilities carousel.png

Read the blog for the latest news

Read the latest about new experiences and capabilities in the Power Automate product blog.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

Users online (3,640)