cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
980Panama
Level: Powered On

Run History Inputs and Outputs Click to Download

I am troubleshooting a Flow and cannot see the data being used as Inputs or Outputs as the message comes up Click to Download.  When I try to download it downloads a txt file with nothing in it (empty) any suggestions please,

 

Capture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Run History Inputs and Outputs Click to Download

Hi @980Panama,

 

Have you found the solution?  If yes, please go ahead and mark your post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
21 REPLIES 21
Super User
Super User

Re: Run History Inputs and Outputs Click to Download

Can you upload a screenshot of the action in edit mode?

980Panama
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

Hi thank you for getting back to me - after checking through I found the syntax was not correct and now it is showing the inputs and outputs ok.

Community Support Team
Community Support Team

Re: Run History Inputs and Outputs Click to Download

Hi @980Panama,

 

Have you found the solution?  If yes, please go ahead and mark your post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Marco_Schade
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

Hi,

 

Can you please share what was the error in the Syntax? I have the same problem and can't seem to get it working. 

980Panama
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

Sorry cannot remember it now (have had so many syntax errors). Anyway it was an incorrect input into the Compose and this was then putting nothing through. If you want to share your compose input statement I can have a look and see if I can spot the problem.

Marco_Schade
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

Hi,

 

Thanks. Yes i will share it.

The weird part is that i have a flow that is more or less identical and it works great. 

The compose action is supposed to give me a specific SQL row as an output. 

 

Flow Output 1.PNGFlow Output 2.PNG

980Panama
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

OK - I am no expert so you may want to wait for a microsoft guru to answer, but as I see it the compose will work against every record and will look for first but I think this would only work against an array and I am not sure that Body works like that.  If what you want to do is just get the first record then use the Top Count in Get Rows and set to 1. Otherwise you could use the filter query if you want to select a specific record, otherwise you could use a condition.

Marco_Schade
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

Hi,

 

As i think you can see in the pictures I am using the filter to get one specific row. I filter on an ID from that list = an ID from the new record created. So this at least should not be the problem. But i really can not figure the problem, but maybe a Guru will be the way to go Smiley Happy 

 

Thanks for you help anyway Smiley Happy 

Super User
Super User

Re: Run History Inputs and Outputs Click to Download

@Marco_Schade 

 

Can you check the output from

 

body(Get_Rows)?['value']

Is this giving you an array?

 

The first fucntion will work on an array. It looks like you might be battling with the location of the array of data

 

 

 

 

Marco_Schade
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

Hi Pieter

 

I can't see the output, that is the problem.

I have another flow where this is working perfectly and it gives me this output:

It is each column from the SQL. 

 

Capture7.PNG

Super User
Super User

Re: Run History Inputs and Outputs Click to Download

Is that the missing output from the first function or from the value property?

 

Can you see any output from just body('Get_rows')?

 

 

980Panama
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

Guru now on the job.  I would also add the top count = 1 and then you would not need first function as you will only get one returned.  I would also use a condition to check that body is not empty because you may have the case that it does not exist.

Marco_Schade
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

That is the output from another flow where a similar set of actions works great. 

This is the output i get when i leave out First and values:

Flow Output 3.PNG

Marco_Schade
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

I am not sure where to add this "I would also add the top count = 1 and then you would not need first function as you will only get one returned."

980Panama
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

add it in Get Rows Maximal Antal just put 1 in there

Super User
Super User

Re: Run History Inputs and Outputs Click to Download

The problem is as simple as your get rows isn't returning any data, hence the empty array.

 

Time to investigate the get_rows action.

 

Can you take the filter out and see what the data looks like.

 

The problem is either the ID field or the value that you are checking against.

980Panama
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

Use this condition in a condition after Get Rows to check whether there is any data found or not

 

length(body('Get_items')?['value'])
 
There will be a dropdown for equal and then add 0 and branch to either side of condition with functionality
 
For useful debugging (and as a temporary measure) you could show both ID and FabrikID in 2 separate compose statements before the condition
 
I can see ID in your fields but not FabrikId
Marco_Schade
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

It seems that the flow gives the desired values. 

 

Flow Output 4.PNG

980Panama
Level: Powered On

Re: Run History Inputs and Outputs Click to Download

What is the value of ID - I can see FabrikId = 3 but I believe you are using ID from this dataset to match with FabrikId from your first dataset.  Are ID and FabrikId the same values 

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 348 members 5,159 guests
Please welcome our newest community members: