cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
tcvall86
Advocate II
Advocate II

Run flow from SharePoint list using For Selected Item in Solution does not work for some users

Hello all.

We have project where I have a Sharepoint Issue tracker list and have added some run flow buttons there like this

tcvall86_0-1614767888161.png

https://github.com/pnp/sp-dev-list-formatting/tree/master/column-samples/generic-start-flow

tcvall86_2-1614768247600.png


Usually what I need to do to make this work (if created the flow outside of solution) is adding the list as a shared connection for run only users

tcvall86_1-1614768054093.png

In Solutions this option is not available.
However this works for all users I have tested with anyway except for one.
Unless I break out the flow outside of the solution and add the above (sharing with list) the button will do nothing for that specific user.

Since it is only one user who is affected I am a bit curious. Ofcourse I could break it out outside of solution but I like to have everything connected to this project in the same place.

Perhaps is it actually a bug that it works for some users and this is not supported in Solution yet? Or am I missing something obvious here

Edit: Just to be clear, yes I can also give the user specific run user permissions on the flow and it will also work. Still confusing that it works for almost all users. 

Thanks in advance!
Regards,
Thomas 

0 REPLIES 0

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (5,451)