cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
gm355
Level: Powered On

Saving email to FTP

I'm trying to create a simple Flow where I save an email onto an FTP when it gets flagged.

 

It works when I use MessageID as the File name, but the file name is long and cumbersome.

 

When I try to use Subject as the File name I get an error. I also tried setting a variable FileName and assigning the Subject to the variable, but got the same error.

 

Can anyone help please?

 

Thanks.

 

WORKING FLOW:

working.PNG

 

OUTPUT IS LONG AND CUMBERSOME:

 

Long File Name.PNG

 

FLOW USING SUBJECT AND RESULTING ERROR:

 

File Name Subject doesn't work.PNG

Subject error.PNG

FLOW USING FILENAME VARIABLE AND RESULTING ERROR:

 

FileName variable.PNGSubject Fail message.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Saving email to FTP

Hi @gm355 ,

 

What is the Subject of the email?

Does the Subject have some special synbol in it?

Please take a try to name the file with a special string to see if the flow could work.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

 

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Saving email to FTP

Hi @gm355 ,

 

What is the Subject of the email?

Does the Subject have some special synbol in it?

Please take a try to name the file with a special string to see if the flow could work.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

 

View solution in original post

gm355
Level: Powered On

Re: Saving email to FTP

The subject of the email follows this format:

 

example: EXAMPLE, INC. DEAL 45MM 20160907 - Example

 

So it has semi-colon, comma, period and dash.

 

I ran some tests and it seems like it's the semi-colon that is causing the problem (how random)

 

So I need some code to remove the semi-colon.

 

Thanks for you help!

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors
Users online (5,974)