cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Search for user gives empty result

Hello, 

I need your help. I created a PowerApps, wich has a Form. 
In the form there is : 
- One EditForm. I created a Submit button and it creates an item in a SharePoint List. 

- One ListBox with an Office365 connection with the members of my company. When I click on submit, it patches the item to add the name of the employee in a column. 

I want to create a Flow to notify the employee that an Item was created. I added 10 second to be sure the patching process is done. In the apply to each, I added a condition and then the action send an email. 


The flowThe flow

Empty inputEmpty input

The problem is that the Input is empty, so it sends to 100 people an Email.

The flow works when I create manually an item in the SharePoint list.

Could you help me ?

Thanks a lot 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Search for user gives empty result

Hello, @v-yuazh-msft 
I think I have the solution : 
The visitedPerson is send to SharePoint thanks to a Patch function, so it is empty when the item is created. The action search for users is linked to the created item and that's why the input is empty. 
-> Add a get item after the delay to get the column VisitedPerson. 


View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Search for user gives empty result

Hi @ Martindeter,

 

 

As you said, the problem is that the Input is empty, so it sends to 100 people an Email.

Does the "VisitedPerson" dynamic content in the "Search for users" action is an output of the "When an item is created" action?

Could you please share more run details or the output of the "When an item is created" action?

 

If the "VisitedPerson" dynamic content of the "When an item is created" action is empty, may be there are something wrong on your powerapps to create the item with "VisitedPerson" column, the value of  "VisitedPerson" column in your powerapps hasn't send to the sharepoint list.

 

Please let me know if your find the error and your problem is solved.

 

Regards,
Alice Zhang

Highlighted
Anonymous
Not applicable

Re: Search for user gives empty result

Hello, @v-yuazh-msft 
I think I have the solution : 
The visitedPerson is send to SharePoint thanks to a Patch function, so it is empty when the item is created. The action search for users is linked to the created item and that's why the input is empty. 
-> Add a get item after the delay to get the column VisitedPerson. 


View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (6,878)