cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JulieTE
Advocate I
Advocate I

Select item() on different source than SP get items

Hello, 

 

I am trying to extract all items from an array that I get from a PowerApps request, following some examples I saw where people were doing the same but from a SP list.

PowerApps gives me a string that I split into differents rows, and in those rows I have to split once again to get all fields.

I would like to do a select on those fields to insert them as a row in a SP list.

I can't figure out why I get first fields for all items (see last picture), which multiples unnecessary.

1.PNG2.PNG3.PNG4.PNG

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @JulieTE ,

 

Please try to export this Flow as a .zip file, then re-import as a new Flow, and then configure the relevant connection.

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
v-bacao-msft
Community Support
Community Support

Hi @JulieTE ,

 

Do you mean that the value of each element in the array used by Select is the value of the key you configured in Select?

And are they all sorted according to the index of the array?

I did the test on my side. If it is exactly the same as I described, you could use array[index] to configure Create item action directly.

Select action is more friendly and more applicable to data sources of type array objects.

Image reference:

24.PNG

Please take a try.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Yes it is as you described.

It seems to be working fine if I edit a message ( or compose).

However when I add an item to a list I get the following error , it looks like I can not insert a row into a group SP using this method : 

Capture.PNG

Hi @JulieTE ,

 

Please try to export this Flow as a .zip file, then re-import as a new Flow, and then configure the relevant connection.

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

I don't understand the logic in that but it works, thanks!

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Top Solution Authors
Users online (1,129)