cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ShineTan123
Helper III
Helper III

Send SPL attachment via email but file cannot open

Hi All,

I have a flow to attach the SPL attachment in email, and send email to approver. The flow runs well, and email is able to send as well, but the problem is that the attachment in email cannot be open. 

 

Below is the screenshot of my flow and the error msg when open the attachment, it's an excel file.

It's weird that other flows work quite ok, just this one not working. Even I tried to create a new flow, it's still the same problem. Hope anyone can help.

ShineTan123_0-1658997544684.pngShineTan123_1-1658997605562.pngShineTan123_2-1658997681351.png

ShineTan123_3-1658997709666.png

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @ShineTan123 ,

 

Please use Attachment Content:

ekarim2020_0-1659008794490.png

 

ekarim2020_1-1659008933868.png

After you save, close  and re-open the flow, the Attachment Content display name will appear as "Body" although the expressions behind the scenes are exactly the same:

ekarim2020_2-1659009010889.png

 


Ellis
____________________________________
If I have answered your question, please mark the post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
ekarim2020
Super User
Super User

Hi @ShineTan123 ,

 

Please check the Append to array action and how you are adding the array variable to the Send an Email action:

Snag_101e1ba1.png

 Ellis
____________________________________
If I have answered your question, please mark the post as Solved.
If you like my response, please give it a Thumbs Up.

Hi @ekarim2020,

This is in the array action. Looks like it's not getting the body of get attachment content.

But I cannot find body of get attachment content.

ShineTan123_0-1659007228574.png

ShineTan123_1-1659007471678.png

 

 

Hi @ShineTan123 ,

 

Please use Attachment Content:

ekarim2020_0-1659008794490.png

 

ekarim2020_1-1659008933868.png

After you save, close  and re-open the flow, the Attachment Content display name will appear as "Body" although the expressions behind the scenes are exactly the same:

ekarim2020_2-1659009010889.png

 


Ellis
____________________________________
If I have answered your question, please mark the post as Solved.
If you like my response, please give it a Thumbs Up.

Hi @ekarim2020,

Thanks! The problem is fixed.

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (2,422)