cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RABronn
Helper I
Helper I

Send an HTTP request to SharePoint is not working (worked 2 days ago)

Hi, 
I have a flow that creates a document set. I'm following guides online since I don't know what I'm doing. My test flow worked on Wednesday, but does not work today (bad gateway error). I have tried creating a new (simplified) flow for testing. This is what I'm working with:

 

RABronn_0-1651854494172.png

 

I managed to create this document set via flow on Wednesday (by testing the flow), so it was working initially.

RABronn_1-1651854646704.png

How can I get it to work again?

1 ACCEPTED SOLUTION

Accepted Solutions
Expiscornovus
Super User
Super User

Hi @RABronn,

 

Have you tried it with a different document set name? Or did you try to create a document set with the same name again (in your screenshot the name is Test).

 

Every new document set should have it's own unique name. Try changing Test to Test2 to see if that makes a difference?

 

createdocumentset_listdatasvc02.png

 

View solution in original post

4 REPLIES 4
Expiscornovus
Super User
Super User

Hi @RABronn,

 

Have you tried it with a different document set name? Or did you try to create a document set with the same name again (in your screenshot the name is Test).

 

Every new document set should have it's own unique name. Try changing Test to Test2 to see if that makes a difference?

 

createdocumentset_listdatasvc02.png

 

Hi @Expiscornovus 

 

Thank you for your help. Yes, the document set name was different. My flow was slightly different to yours though, so I tried your version and it succeeded. 

In the interest of making my flow more dynamic for different document set types, could you expand on the syntax for the Content Type StringId retrieved from your first HTTP request? The one that starts with "body(".

Expiscornovus
Super User
Super User

Hi @RABronn,

 

Yes, sure. No problem.

 

Btw, that expression was also stored in the comments section of the action in my previous screenshot 😁

 

body('Send_an_HTTP_request_to_SharePoint')['value'][0]['StringId']

 

expression_in_notes.png

Hi @Expiscornovus 

 

Ah, I see it now, thank you!

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (2,880)