cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sunithav
Helper IV
Helper IV

Send email action fails with "One or more recipients are invalid." error

I have created a flow that sends email to email address saved in a "single line of text" column in a SharePoint list. Email addresses are separated by ";". When I add this column to To/CC field in the send email action, a new line character gets introduced if the email address contains numeric value. For e.g. if the addresses saved in column is abc13@xyz.com;abc05@xyz.com  it appears as below(new line after 13 and 05) in email making it an invalid email address. Has anyone experienced this problem?  

 

abc13

@xyz.com;abc05

@xyz.com

2 ACCEPTED SOLUTIONS

Accepted Solutions

Oops!

Still unclear to me the reason for the bloddy New Line. Is your SP column declared as rich text or so? Jsut guessing what the problem can be...

 

Another dirty trick:

Let's assume your list of emails is stored in a variable called 'currentEmailList'

Create a dummy Compose (let's call it Compose), add a new line as its value (just hit enter)

Create a second Compose (let's call it Compose 2), use replace() function to remove the new lines:

replace(variables('currentEmailList'),outputs('Compose'),'')

Use this second Compose to fill To / CC

 

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

 

Hi @sunithav ,

 

You can store the value of this field in Compose first. After running Flow, if the output of Compose is shown in the following figure, you can refer to the following method to achieve your needs.

32.PNG

Method:

33.PNG34.PNG

Please take a try.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

14 REPLIES 14
v-bacao-msft
Community Support
Community Support

 

Hi @sunithav ,

 

Could you share screenshots of Flow configuration and Flow run history?

Is the value of this field in the list and the body of the action as expected?

You could try the trim() function to format the value of this field.

Like:

28.PNG

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Barry,

 

The value in the field is not reflecting in the body of the action. The value in the body of the action has a "new line" character introduced. 

Trim() function did no difference. 

 

Thanks,

SV

efialttes
Super User III
Super User III

Hi

Does this problem happen both when your sharepoint item column stores one email (i.e. no ';') and also when it stores more than one email address?

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Hi,

 

Send email was successful for one email address. The email address which broke into two lines when added along with other email address works fine if only it added to the column.

 

Generally, the email address mentioned at the end in the string and prior to it breaks into two lines.

 

Thanks,

SV

Mmmm....

Can you try to add a ; at the end of one of your email address lists, just for testing purposes, and see if the problem is solved, persists, or gets even worse?



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Adding ";" at the end of the email addresses with ";" works fine. That's one way that we have thought of making this work.

 

Whats unknown to us is how the "new line" is getting introduced in the email address. 

 

Thanks,

SV

Hi again

I agree with you it still sounds weird, but at least we have a workaround up and running 😁

Please note you can automate the addition of the semicolon at the end of your list of emails by means of Power Automate and

function concat()

Hope this helps

 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Update - Adding ";" at the end of the email address failed. The workaround doesnt work.

 

Thanks,

SV. 

Oops!

Still unclear to me the reason for the bloddy New Line. Is your SP column declared as rich text or so? Jsut guessing what the problem can be...

 

Another dirty trick:

Let's assume your list of emails is stored in a variable called 'currentEmailList'

Create a dummy Compose (let's call it Compose), add a new line as its value (just hit enter)

Create a second Compose (let's call it Compose 2), use replace() function to remove the new lines:

replace(variables('currentEmailList'),outputs('Compose'),'')

Use this second Compose to fill To / CC

 

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

 

Hi @sunithav ,

 

You can store the value of this field in Compose first. After running Flow, if the output of Compose is shown in the following figure, you can refer to the following method to achieve your needs.

32.PNG

Method:

33.PNG34.PNG

Please take a try.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Interesting trick. I will give this a try and let you know how it goes.

Thank You

SV

Thanks @efialttes  and  @v-bacao-msft. The fix suggested worked.  

 

@v-bacao-msft , The data saved in SharePoint list is output of HtmlToText conversion action. The line break was introduced in this step. Do you know why/how random line break get added? Is this a known issue?

 

Thanks,

SV

 

Hi @sunithav ,

 

I am glad that our suggestions are helpful to solve this issue.

I am afraid that I don’t know why this issue appeared on your side. I have made a test on my side but cannot reproduce the same issue.🤔

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

HURRAY!

IT WORKS!

 

My humble suggestion:

1.-Thanx for marking this topic as "Solved" by clicking "Accept as a solution" on the right answers. This is the way other community members facing this same problem in the future can find a solution faster

Flow_AcceptSolution.png

2.- Since we cannot reproduce the second issue, open a new thread following the policy: 'One Question, one post'. Many Super Users do pay special attention to topics with 0 responses, and this one has too many so far

3.- (OPTIONAL) Click on 'Thumbs up' in any answer you found valuable in the current topic, if not all

Flow_thumbsUp.png

Even though this 3rd step is OPTIONAL, please remember it is the cheapest, easiest way to say thanks to somebody that simply tried to help. And just between you and me, everytime an inspiring answer receive a kudo, an ewok escapes from The Emperor menace  😉

 

Thanx for taking the time to mark this topic as solved!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (1,870)