cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Send email from shared mailbox - "Resource could not be discovered"

Dear

I am in the process of creating a flow to send an email from a shared mailbox and receive the following error when running:
Status code = 404
{
"status": 404,
"message": "Resource could not be discovered.\r\nclientRequestId: b1f97f82-706e-4804-a510-6e4088215bc9\r\nserviceRequestId: 159481e6-474a-4f1b-8866-2725dd0dc8ad",
"source": "office365-eus.azconn-eus-01.p.azurewebsites.net"
}

 

My account has fulll access to the shared mailbox and it is being used as account for the connector.


I would really appreciate any kind of help or pointers in how this can be solved 🙂

Thanks
Regards
Farzad

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

 

Hi @Ftejani ,

 

Flows fail if a setting in an action of the flow doesn't function as expected. In this case, the error message contains Bad request or Not found, or an error code of 400 or 404 appears.

Please share the details of the Flow configuration so that we can analyze the issue.

 

In addition, you should pay attention to the following two points when configuring the action related to Shared mailbox:

  • The account that configures the connection (in this case, your account) needs to be a member of the Shared mailbox.
  • You need to remove semicolon at the end of the Mailbox Address.

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Highlighted
Community Support
Community Support

 

Hi @Ftejani ,

 

Flows fail if a setting in an action of the flow doesn't function as expected. In this case, the error message contains Bad request or Not found, or an error code of 400 or 404 appears.

Please share the details of the Flow configuration so that we can analyze the issue.

 

In addition, you should pay attention to the following two points when configuring the action related to Shared mailbox:

  • The account that configures the connection (in this case, your account) needs to be a member of the Shared mailbox.
  • You need to remove semicolon at the end of the Mailbox Address.

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (8,777)