cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Send email to an Outlook 365 group

 

Hi,

 

I'm trying to create a flow that sends an email to the team when a document is created in our team's document folder.  I have created the flow with just myself as the reciprient of the email and it works fine.  The issue I have is that when I try to enter the Office 365 Group name in the To: field, the autofill doesn't see it.  Autofill sees all the email addresses of each individual in the company but it doesn't see any of our 365 groups (or our older distribution lists for that matter).  I can type in the full name of the group ignoring the 'no items found' and save the flow successfully.  When the flow is triggered it will show that the flow was executed successfully but no email is ever received by anyone in the group.  I tried turning on 'allow outside senders' for the 365 group just in case but that had no affect.

 

Any help would be appreciated.

 

Thanks,

 

Joe

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Kris,

 

Thanks for the follow-up.  I'm completely new to all this so it's good to know that I wasn't doing something wrong.  You are correct in that emails were in fact being sent to the group email inbox.  I didn't think to look there - it's not something we've been making use of.  This isn't ideal but I can make it work.

  

Thanks,

 

Joe

View solution in original post

16 REPLIES 16
Community Support
Community Support

Hi @jsheredy,

 

Could you please share a screenshot of your flow's configuration?

 

The issue is confirmed on my side, the To field of "Send an email" action would resolve individual email address in my Office 365 group or organization automatically. Resolving group email address automatically is not supported in To field of "Send an email" action of Outlook connector in Microsoft Flow currently, if you would like this feature to be added in Microsoft Flow, please submit an idea to Flow Ideas Forum:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

 

In addition, the "Send an email" action could send emails to a group email address, but the members of the group could only receive the email in their group mailbox rather than their own mailbox:25.JPG

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Kris,

 

Thanks for the follow-up.  I'm completely new to all this so it's good to know that I wasn't doing something wrong.  You are correct in that emails were in fact being sent to the group email inbox.  I didn't think to look there - it's not something we've been making use of.  This isn't ideal but I can make it work.

  

Thanks,

 

Joe

View solution in original post

Hi, 

 

I'm having the same issue and I believe it's a bug.

 

If I send an email from Outlook to the email address of the group, the email goes to all of the members and shows up in their inbox.  If I use Flow to do the same thing, it ends up in the Group mailbox.

 

Shouldn't the behavior be the same when Flow sends the email using that address as it is using Outlook?

 

Liz

 

Anonymous
Not applicable

Hi,

On one of my Flows,

I'm unable to search for office365 group on Outlook-Send an Email. when i search for group it says no items.

Is there any way to find office365 groups.

 

Thanks

Last I checked this is still not supported.  It's a major miss in my opinion.  What could be more natural than wanting to send an email to the group tied to the flow?  Whenever we add new people to a group I have to not only add them to the group but then make sure I go back and update any flow that group is involved in.  PITA!

 

Joe

I'm also unable to send an email via Outlook in Flow to a distribution list.  The to: doesn't recognize it.

Same here. This is crazy as Groups have been around for how long...........

Frequent Visitor

Try using the full internet address of the group?

I swear I had tried several iterations of that way back when and couldn't get it to work but now it is.  Thanks for the refresh - so much easier this way!

 

Joe

Awesome!!! You're welcome. It makes the Exchange server do the lookup of the group instead of FLOW. I ran into that many times in other development of apps. 

Anonymous
Not applicable

Can you explain what the full internet address would be?  I am having this problem myself, it's a major issue.  Thanks.

I sure can... Your SMTP email address:

NAME@Yourcompany.com

I entered the full distribution group address and still not working.  Any suggestions?

can you give an examle of what the format looks like?

 

 Does the flow fail?

Frequent Visitor

I was having just this issue and now have found it works using the below technique:

  1. If the address you type won't reconcile, click the box to switch to advanced mode
    martinconroy_3-1613494164540.png
  2. Enter the email addresses separated by semi-colons as indicated
  3. Click the icon again to switch back to "Basic" mode, and the group addresses that wouldn't reconcile now mysteriously have!
    martinconroy_4-1613494324671.png

     

 

Helpful resources

Announcements
Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Microsoft Ignite

Microsoft Power Platform: 2021 Release Wave 1 Plan

Power Platform release plan for the 2021 release wave 1 describes all new features releasing from April through September 2021.

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (18,573)