cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KyleDoddemeade1
Frequent Visitor

Send email when new item is created (Validation Issues)

Hi All,

 

Apolgies if this has been answered previously but I am having diffculty finding the answer.

 

I'm fairly new to sharepoint (about 2 days) and I have been tasked with an excerise that involves creating a flow for onboarding. The aim is when a new item (employee) is added to a list then the flow will send 2 emails out, one to the line manager and team lead, then to the new employee.

 

So far everything has run smoothly but I am now stuck on validation (if i'm using the right phrase).

 

Issue: When the first record is added it is fine, however soon as I add more items - it sends the previous existing users as well. From what I can see i'm not specifying that what needs to be sent is the new item details, however I am unsure on how to over come this.

 

Any advice would be greatly appreciated:

 

Flow Screenshots below:

1.PNG2.PNG3.PNG4.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Gristy
Resident Rockstar
Resident Rockstar

Hey

 

The problem is instead of using the trigger values, you are querying the list and retriving likely using a Get Items by the look of it (hard to tell as you have renamed).

 

Delete the action "Get New Starter"/"Get New Starter2" and use dynamic data from the trigger body.

 

You probally do not need to branch and repeat a lot of the same actions for the two emails either, but may get the first part fixed first.

 

Cheers

 

Chris

View solution in original post

2 REPLIES 2
Gristy
Resident Rockstar
Resident Rockstar

Hey

 

The problem is instead of using the trigger values, you are querying the list and retriving likely using a Get Items by the look of it (hard to tell as you have renamed).

 

Delete the action "Get New Starter"/"Get New Starter2" and use dynamic data from the trigger body.

 

You probally do not need to branch and repeat a lot of the same actions for the two emails either, but may get the first part fixed first.

 

Cheers

 

Chris

View solution in original post

Hi Chris,

 

Many thanks, I implemented your reccomendation this morning and it all seems to be working (albiet a bit of tidying up is needed).

 

If you have a resource to tidy up the branching and repetitive actions that would be great.

 

thanks

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,082)