cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Markie Helper II
Helper II

Send mail failing with format numbers

Hi,

 

My Send Mail action fails because output of Format numbers cant be processed, message error:

 

Unable to process template language expressions in action 'SendVerificationRequest_2' inputs at line '1' and column '2803': 'The template language expression 'body('TotalOver8')?['body']' cannot be evaluated because property 'body' cannot be selected. Property selection is not supported on values of type 'String'. Please see https://aka.ms/logicexpressions for usage details.'.

 

Here is my TotalOver8 number format flow step:

 

totalover8.PNGAny ideas what might be the issue? It seems to be working just fine on friday.

1 ACCEPTED SOLUTION

Accepted Solutions
SamPo Impactful Individual
Impactful Individual

Re: Send mail failing with format numbers

@Markie Try removing the dynamic content, instead enter a custom expression with the following value:

outputs('TotalOver8')?['body']

2020-04-06_1434.png 

View solution in original post

6 REPLIES 6
SamPo Impactful Individual
Impactful Individual

Re: Send mail failing with format numbers

@Markie When using the format number activity, you should be using the 'outputs' command to get the number. See the example below: 
2020-04-06_1351.png

Markie Helper II
Helper II

Re: Send mail failing with format numbers

@SamPo This is what im doing: 

 

totalover8.PNG

 

SamPo Impactful Individual
Impactful Individual

Re: Send mail failing with format numbers

@Markie What is the code you see when you hover over the item? Have you tried removing it and re-selecting it from the dynamic content window?

Markie Helper II
Helper II

Re: Send mail failing with format numbers

@SamPo 

 

I've already tried removing & adding dynamic content this is the code:

 

totalover8.PNG

SamPo Impactful Individual
Impactful Individual

Re: Send mail failing with format numbers

@Markie Try removing the dynamic content, instead enter a custom expression with the following value:

outputs('TotalOver8')?['body']

2020-04-06_1434.png 

View solution in original post

Markie Helper II
Helper II

Re: Send mail failing with format numbers

That did the job! Thanks!

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Automate Community!

firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Users online (6,386)