cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mccardj
Helper IV
Helper IV

Sending a hyperlink never works

Hi all,

 

I'm really struggling to get something as simple as a hyperlink to send via the "Send an email (V2)" action from a SharePoint list.

 

Use case:

I create a new SharePoint item and type my message in the "Message" field (which is Multiple lines of text, RTE enabled). I then click "Add or edit hyperlink", copy the hyperlink in and type in the text to display - all good so far.

Screenshot (5).png

Screenshot (3).png

When I start the flow to send the email, I have the dynamic content "Message" field in HTML and the content of the message displays correctly, but the hyperlink always displays with [/sites/"the SharePoint site name"]"Name of the hyperlink". You cannot open or click the hyperlink which you'd expect.

 

Any ideas would be greatly appreciated! Jack

 

Screenshot (6).png

 

The hyperlink always appears something like this.....

Screenshot (4).png

8 REPLIES 8
Mira_Ghaly
Dual Super User
Dual Super User

@mccardj 

I just need to understand you correct the link is saved in your sharepoint list?

Can you share a screen shot for a sample item in your sharepoint list.

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Hi, I don't save the link in my sharepoint list because I want the link to be embedded within the "Message" dynamic content in my email, e.g.

 

"Hi all, We had a good workshop today. Please find the link here to view the minutes. Thanks again"

 

In the above scenario, the "Message" field contents everything in quotations (basically the body of the email) and the hyperlink is contained within the body of the email.

 

Does that make sense?

 

The full flow is below.

 

Screenshot (8).png

@mccardj 

Can you try to append http:// or https:// to the URL as below:

Mira_Ghaly_0-1595499450450.png

I tried it and worked on my side 

 

Please mark as accepted solution if this helped you.

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Thanks for the suggestion but I had already tried that and it didn't work. I have just selected the "Switch to classic experience" button and selected "Edit source" to view the underlying HTML. What I discovered is that SharePoint strips the domain server as soon as I press OK to save the SharePoint item. When I go back to insert the domain server (e.g. https://mycompany.com) it strips it again. See image, it stripped the domain name and left "/:x:/r.... onwards"

 

Screenshot (9).png

Mira_Ghaly
Dual Super User
Dual Super User

@mccardj

In your shared screenshots why you are not using the Message in the Body, do you need to format the email? 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Yes the Message is in the Body and I do format the body with HTML but even if I don't the domain name always get stripped no matter what I do. 

Does it do the same on your end? 

@mccardj it worked fine at my side when I added http://

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

@mccardj

My other suggestion is to do  compose data operation with  replace expression to the part in url with your site name with '' and use the output in the body of the email. 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,386)