cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Sending an email with an attachment

Hi all, I am looking to send emails with a unique file attached to each. I have uploaded all of these to a SharePoint folder. I run a list rows present in excel table. This file contains the identifier for each file alongside the recipient's email address. The issue I am having is that the flow isn't finding the file in the SharePoint folder. Attached is my flow, along with sample failure, and my file in the sharepoint I am attempting to attach


image.jpg

 

Untitled.pngUntitled (1).pngjcoughlan_1-1597232461854.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

Hi all,

found a solution. My issue was I had been putting the file name in the file identifier option in 'Get file content', rather than the id.

View solution in original post

5 REPLIES 5
ChristianAbata
Community Champion
Community Champion

hi @Anonymous  you need to add in file name the extension of the file like .pdf ot other



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
v-litu-msft
Community Support
Community Support

Hi @Anonymous,

 

You should add the folder into the file identifier, then use the uriComponent() function convert these characters into URI code:

/Shared Documents/LastName.extension
uriComponent(outputs('Compose'))

Annotation 2020-08-13 105853.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

Hi @v-litu-msft

Many thanks for your help. 

However this does not seem to be working for me.

jcoughlan_0-1597312483393.pngjcoughlan_1-1597312503428.pngjcoughlan_2-1597312516238.png

 

Hi @Anonymous,

 

Could you please remove the blank space and try it again?

Annotation 2020-08-17 143453.jpg

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

Hi all,

found a solution. My issue was I had been putting the file name in the file identifier option in 'Get file content', rather than the id.

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Users online (1,517)