cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SunshineK
Helper II
Helper II

Set condition always returning false (despite true)

Hi team, 

 

Please help. 

I know there have been many posts about this and I have read and tried a number of solutions however it has not worked for me (though did fix one problem). 

I have used the exact same on another flow with no issues.

 

Issue: condition returning false

 

My flow: 

condition set as if Asset Identification is 'Yes' then... 

SunshineK_0-1607639493836.png

 

Excel spreadsheet:

SunshineK_1-1607639766544.png

 

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions

I deleted the flow - and restarted it using the exact same flow and it worked!

Bug?? Not sure but thank you @abm for your input.

View solution in original post

10 REPLIES 10
abm
Super User
Super User

Hi @SunshineK 

 

From your run history its difficult to analyse it. Could you please post a screenshot of your Flow mappings of the condition? Are checking yes as it is.



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Please see below. 

It is simple - hence why I am so confused. It has been working until recently. 

 

SunshineK_0-1607645358613.png

 

Hi @SunshineK 

Thanks for posting the screenshot. Could you please check the first step run history and see what its returning?



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Another option is add a Compose action after the trigger and map this dynamic value

 

image.png

 

Once you ran check the run history and see what value is returned in compose action step. If that returned yes then try to covert using the expression string() under your IF condition. That might do the trick.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Thank you. 

 

SunshineK_0-1607658492155.png

 

What do I use to do: 

 

"

If that returned yes then try to covert using the expression string() under your IF condition. That might do the trick.

"

Hi @SunshineK 

Under the If condition where you mapped the below dynamic value. Use the expression string() and place the below value.

 

image.png

 

image.png



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Hi @SunshineK 

 

Did you resolved your issue? 

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

thanks @abm 

 

No luck unfortunately - returns this error:

 

There is an unterminated string literal at position 14 in 'objectid eq '9'.
inner exception: There is an unterminated string literal at position 14 in 'objectid eq '9'.

 

 

 

 

 

All my flows that have a condition where IF it is equal to Yes or No - it returns false. 

These are conditions set from Survey123 and SharePoint List. 

Yet to find a solution. 

I deleted the flow - and restarted it using the exact same flow and it worked!

Bug?? Not sure but thank you @abm for your input.

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Users online (5,743)