cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Setting multi-user field to blank

Hi,

 

I have a SharePoint document library that has a few multi-user fileds (Approver L1, Approver L2, Approver L3). I am setting these fields to blank using the Https request action. That works all fine. However, the issue that I am running into is that when I open a document in word desktop application it gives me save error. That's because instead of blanking out the user fields it's setting it up as 0. Please advice

Capture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

Re: Setting multi-user field to blank

I resolved this issue. The user field was updating incorrectly in the Https action to clear out multiple user field. Instead of

{'__metadata':{'type':'SP.Data.ApprovalTestItem'},

'ApproverId':{'results':[0]}"}]}

I had to use

{'__metadata':{'type':'SP.Data.ApprovalTestItem'},

'ApproverId':{'results':[]}"}]}

 

View solution in original post

4 REPLIES 4
Highlighted
Memorable Member
Memorable Member

Re: Setting multi-user field to blank

Hi @Sr111 

 

Can you please post a screenshot of your Flow so I can try to recreate your scenario on my end?

 

Thanks,

Fausto Capellan, Jr

Fausto Capellan, Jr
Did I answer your question? Mark my post as a solution! Did my response help? Please give it a thumbs up!
Highlighted
Frequent Visitor

Re: Setting multi-user field to blank

I resolved this issue. The user field was updating incorrectly in the Https action to clear out multiple user field. Instead of

{'__metadata':{'type':'SP.Data.ApprovalTestItem'},

'ApproverId':{'results':[0]}"}]}

I had to use

{'__metadata':{'type':'SP.Data.ApprovalTestItem'},

'ApproverId':{'results':[]}"}]}

 

View solution in original post

Highlighted
Memorable Member
Memorable Member

Re: Setting multi-user field to blank

Glad you got that sorted.
Fausto Capellan, Jr
Did I answer your question? Mark my post as a solution! Did my response help? Please give it a thumbs up!
Highlighted
Community Support
Community Support

Re: Setting multi-user field to blank

Hi @Sr111  @SR11 ,

 

Glad to see that you have found a solution to the problem, please click Accept as Solution and mark your post as solved so that more users can learn from your method.

 

Also about Setting multi-user field to blank, are you interested in trying the following method.

  • Initialize an empty array variable and then use this empty array to update the multi-user field.

Image reference:

9.PNG

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (3,889)