cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
drossi
Level: Powered On

SharePoint Add Attachment Bad Request

Hi all,

 

I had a working Flow until today. I'm now getting a 'Bad Request' fail message at add attachment after it 'Get File content using path' executes successfully. 

 

I have a similar condition before it and it works perfectly so I cannot figure out why this is failing.

 

snup.PNG

 

 

3 REPLIES 3
drossi
Level: Powered On

Re: SharePoint Add Attachment Bad Request

It appears it may be because the image files have the same name?

 

I assume you cannot have a file name the same in a SharePoint list?

 

{"statusCode":400,"headers":{"Pragma":"no-cache","x-ms-request-id":"81a4369f-b041-a000-3b21-bb9f8a86d523","Strict-Transport-Security":"max-age=31536000; includeSubDomains","X-Content-Type-Options":"nosniff","X-Frame-Options":"DENY","Timing-Allow-Origin":"*","x-ms-apihub-cached-response":"true","Cache-Control":"no-store, no-cache","Date":"Tue, 18 Feb 2020 11:42:23 GMT","Set-Cookie":"ARRAffinity=9a53c9d953bbdfc85fcb9bc388522492211961687fcde0ee871a9a717de0c346;Path=/;HttpOnly;Domain=sharepointonline-we.azconn-we.p.azurewebsites.net","Content-Length":"643","Content-Type":"application/json","Expires":"-1"},"body":{"status":400,"message":"The specified name is already in use.\n\nThe document or folder name was not changed. To change the name to a different value, close this dialog and edit the properties of the document or folder.\r\nclientRequestId: e7deec03-5b49-42b3-aaa0-02871819e9ef\r\nserviceRequestId: 81a4369f-b041-a000-3b21-bb9f8a86d523","source":"https://xxxsharepoint.com/sites/EngineerLeads/_api/web/lists(guid'0fdb7e18-4608-4a92-8417-a545a8184e...}

 

Super User
Super User

Re: SharePoint Add Attachment Bad Request

hi @drossi  some time I get the same Error is like an server error so, the MSFT evantually fix that kind of errors.

If not, try changing your user conextion creating another one.

change.PNG





Did I answer your question? Please consider to Mark
my post as a solution! to guide others 😉


Proud to be a Flownaut!





drossi
Level: Powered On

Re: SharePoint Add Attachment Bad Request

Thanks for the tip.


I ended up fixing it by renaming the file to include a distinct file name. As when there was a filename with the same name, it just fails.

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons in April

Read the announcement for more information!

firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (4,916)