cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
EdwardC
Helper III
Helper III

SharePoint - Creating Folders

Hi there,

 

I'm stuck on getting my flow to work on SharePoint to create folders for all people in a group.

Flow1.png

 

I kept getting this error (I removed IDs):

{
"status": 400,
"message": "The expression \"web/GetFolderByServerRelativePath(decodedurl=’/sites/service/completed clients archive’)/AddSubFolderUsingPath(decodedurl=’Catherine Li’)\" is not valid.\r\nclientRequestId: removed \r\nserviceRequestId: removed",
 
"Microsoft.SharePoint.Client.InvalidClientQueryException"
]
 
I've checked out this link:
 
and tried this:
 
Both didn't work. 
Anyone know why?
 
Thanks in advance!
1 ACCEPTED SOLUTION

Accepted Solutions
v-bacao-msft
Community Support
Community Support

Hi @EdwardC ,

 

Please pay attention to the use of symbols. If you copy Uri directly from the blog, you need to pay attention to whether the symbols conform to the specifications.

Please reconfigure the single quotes and use the single quotes in English.

6.PNG

You could copy the Uri I provided directly and change the list name and folder name.

_api/web/GetFolderByServerRelativePath(decodedurl='/lists/TestCal')/AddSubFolderUsingPath(decodedurl='foldername1')

If the following error occurs, remove the slash in front of the lists, as below:

"Server relative urls must start with SPWeb.ServerRelativeUr“

_api/web/GetFolderByServerRelativePath(decodedurl='lists/TestCal')/AddSubFolderUsingPath(decodedurl='foldername1')

Flow run history:

7.PNG

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
v-bacao-msft
Community Support
Community Support

Hi @EdwardC ,

 

Please pay attention to the use of symbols. If you copy Uri directly from the blog, you need to pay attention to whether the symbols conform to the specifications.

Please reconfigure the single quotes and use the single quotes in English.

6.PNG

You could copy the Uri I provided directly and change the list name and folder name.

_api/web/GetFolderByServerRelativePath(decodedurl='/lists/TestCal')/AddSubFolderUsingPath(decodedurl='foldername1')

If the following error occurs, remove the slash in front of the lists, as below:

"Server relative urls must start with SPWeb.ServerRelativeUr“

_api/web/GetFolderByServerRelativePath(decodedurl='lists/TestCal')/AddSubFolderUsingPath(decodedurl='foldername1')

Flow run history:

7.PNG

Please take a try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Thanks! I didn't realized that tiny detail. I'll keep that in mind next time!

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (21,492)