cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ggryan2021
Frequent Visitor

SharePoint Delete Item - Bad Request

I have a Flow that has been running daily since January 2021 without error. However as of April 30th, it has been failing on the Delete Item action.

 

Error received is as follows:

{
   "statusCode":400,
   "headers":{
      "Vary":"Origin",
      "X-SharePointHealthScore":"2",
      "X-MS-SPConnector":"1",
      "X-SP-SERVERSTATE":"ReadOnly=0",
      "DATASERVICEVERSION":"3.0",
      "SPClientServiceRequestDuration":"6062",
      "SPRequestGuid":"3c7c2d67-e371-4394-97c9-d678789ad785",
      "request-id":"3c7c2d67-e371-4394-97c9-d678789ad785",
      "MS-CV":"Zy18PHHjlEOXydZ4eJrXhQ.0",
      "Strict-Transport-Security":"max-age=31536000",
      "X-FRAME-OPTIONS":"SAMEORIGIN",
      "Content-Security-Policy":"frame-ancestors 'self' teams.microsoft.com *.teams.microsoft.com *.skype.com *.teams.microsoft.us local.teams.office.com *.powerapps.com *.yammer.com *.officeapps.live.com *.office.com *.stream.azure-test.net *.microsoftstream.com;",
      "MicrosoftSharePointTeamServices":"16.0.0.21221",
      "X-Content-Type-Options":"nosniff",
      "X-MS-InvokeApp":"1; RequireReadOnly",
      "Timing-Allow-Origin":"*",
      "x-ms-apihub-cached-response":"true",
      "Cache-Control":"max-age=0, private",
      "Date":"Mon, 03 May 2021 12:44:35 GMT",
      "P3P":"CP=\"ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI\"",
      "X-AspNet-Version":"4.0.30319",
      "X-Powered-By":"ASP.NET",
      "Content-Length":"188",
      "Content-Type":"application/json",
      "Expires":"Sun, 18 Apr 2021 12:44:30 GMT",
      "Last-Modified":"Mon, 03 May 2021 12:44:30 GMT"
   },
   "body":{
      "status":400,
      "message":"Exception from HRESULT: 0x80131904\r\nclientRequestId: 3c7c2d67-e371-4394-97c9-d678789ad785\r\nserviceRequestId: 3c7c2d67-e371-4394-97c9-d678789ad785"
   }
}

 

1 ACCEPTED SOLUTION

Accepted Solutions

Turning off concurrency on the Apply To Each resolved the issue,  but now it takes quite long.

View solution in original post

2 REPLIES 2
ggryan2021
Frequent Visitor

Screen shot of first two steps:

 

Flow 1.png

 

Turning off concurrency on the Apply To Each resolved the issue,  but now it takes quite long.

View solution in original post

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (28,449)