cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
N-Wilfried
New Member

SharePoint Delete Item - Bad Requests Error

Hi all, 

I'm hoping someone can help me with this problem I'm currently having.

I've created a simple schedule cloud flow where I want to archive items from one SharePoint list (A) to the archive SharePoint List (B) and delete those items from list A when a condition is met, the problem I'm having is the flow gets an error during the deleting stage. What's odd is this flow I've created was working perfectly fine for 3 weeks but for whatever reason, it doesn't anymore. Can someone point me in the right direction.

 

Here is the flow:

N-Wilfried_0-1621324814847.png

 

Here is where the error occurs:

N-Wilfried_2-1621325104056.png

Note: On this screenshot, the 'Create Item' is not shown on the image above however it would be placed above the 'Delete item'

 

Here are the columns:

N-Wilfried_3-1621325297173.png

 

Thanks for any help

1 REPLY 1
v-LilyW-msft
Community Support
Community Support

Hi @N-Wilfried 

 

Thank you for posting.

When a cloud flow fails and the message contains Bad request,it means a setting in an action of the flow doesn't function as expected.

You can try correct the failure according to the error details on the right page.

v-LilyW-msft_1-1621414985287.png

 

For more info about Troubleshooting a cloud flow, you can refer to this document:

https://docs.microsoft.com/en-us/power-automate/fix-flow-failures

 

Hope the content above may help you.

Best Regards

Lily

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,856)