cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KLD
Helper I
Helper I

SharePoint Designer 2013 workflow starting PowerAutomate and stuck

As you probably know Microsoft as turning off SharePoint Designer 2010 workflows on 1 march 2021. We have an existing SharePoint 2013 workflow where we would like to execute a PowerAutomate. We do some logic before and after. When we test the SharePoint Designer 2013 Workflow the logic before works, the PowerAutomate logic works, but after the PowerAutomate is finished the SharePoint Designer 2013 Workflow is stuck. Who know what is going on? Are there other people where it is working between SharePoint Designer 2013 workflows and PowerAutomate flows?

 

ps. I am executing the PowerAutomate in a SharePoint Designer 2013 workflow by the HTTP Call Web Service action as on this blog.

2 ACCEPTED SOLUTIONS

Accepted Solutions
KLD
Helper I
Helper I

I found the solution. I was doing some logic to log after running the PowerAutomate. There was a bug.

View solution in original post

Hi @KLD ,

 

I think you call the Power automate through the following method: 

JisungHan_0-1608990439044.png

 

Receive and respond to calls by using HTTPS - Azure Logic Apps | Microsoft Docs

 

Do you need to return a result values from the Power automate?

 
 

image.png

 

If there is no result that is required, I think the SharePoint 2013 workflow may move to the next action without waiting for the response. If the response takes longer than timeout limits of the SP2013 workflow, then, this would be an issue.

 

Do you resolve this issue? If possible, please add simple note,

1. Which product has a bug? (Power automate or SP2013 workflow)

2. How did you solve this issue

 

Thanks for your help.

 

Best regards,

Jisung Han

 

View solution in original post

4 REPLIES 4
Ferrisma
Helper I
Helper I

SharePoint Designer 2010 workflows deprecated Nov 1st 2020?

Pstork1
Dual Super User III
Dual Super User III

Are you including an HTTP Response action at the end of the flow?  That's what returns control to the SharePoint Designer Workflow.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
KLD
Helper I
Helper I

I found the solution. I was doing some logic to log after running the PowerAutomate. There was a bug.

View solution in original post

Hi @KLD ,

 

I think you call the Power automate through the following method: 

JisungHan_0-1608990439044.png

 

Receive and respond to calls by using HTTPS - Azure Logic Apps | Microsoft Docs

 

Do you need to return a result values from the Power automate?

 
 

image.png

 

If there is no result that is required, I think the SharePoint 2013 workflow may move to the next action without waiting for the response. If the response takes longer than timeout limits of the SP2013 workflow, then, this would be an issue.

 

Do you resolve this issue? If possible, please add simple note,

1. Which product has a bug? (Power automate or SP2013 workflow)

2. How did you solve this issue

 

Thanks for your help.

 

Best regards,

Jisung Han

 

View solution in original post

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Users online (66,852)