cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TomDennison_BDP
Helper I
Helper I

SharePoint Get Items Containing a Choice Column

Hi All: I have a flow that contains several SharePoint "Get Items" actions. One action accesses a SharePoint list that used to have all "Single Line of Text" values. Due to a change in requirements, I needed to change one of the columns to a "Choice" column. Now when I hit the "Get Items" action, it fails. There is a filter query in this "Get Items" action but it does not involve the new Choice column. When I run the flow, I now get the error which seems to indicate the handling of a choice column is an issue. I just need to read the value of each record in a "For each" loop, I don't even need to set it. Any thoughts?  

 

Thanks! Tom

 

ResponseSwaggerSchemaValidationFailure. The API 'sharepointonline' returned an invalid response for workflow operation 'Get_items' of type 'OpenApiConnection'. Error details: 'The API operation 'GetItems' requires the property 'body/value/0/Gap_Status' to be of type 'String' but is of type 'Object'.'

1 ACCEPTED SOLUTION

Accepted Solutions
DamoBird365
Super User
Super User

Hi @TomDennison_BDP 

 

If you've changed the column type after creating the flow, maybe you just need to delete and re-create the get items action as you mention it is not required by the filter.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien


P.S. take a look at my new blog here

View solution in original post

2 REPLIES 2
DamoBird365
Super User
Super User

Hi @TomDennison_BDP 

 

If you've changed the column type after creating the flow, maybe you just need to delete and re-create the get items action as you mention it is not required by the filter.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cheers,
Damien


P.S. take a look at my new blog here

TomDennison_BDP
Helper I
Helper I

This proved to be the issue. I suspect that Power Automate gets a snapshot of the list layout when the flow is created. I recreated anything that referenced this list and it now works fine. Thanks much!

 

Tom

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,181)