cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ericonline
Community Champion
Community Champion

Shared Inbox Trigger: "The specified object was not found"

Hello,

I'm not able to get the O365Outlook- When an email arrives in a shared inbox, to work. I get a 404 error and the following message:

- Our security team added me as a member of the Shared Inbox

image.png

1 ACCEPTED SOLUTION

Accepted Solutions

@ChristianAbata ,

I created a new Flow, new trigger, connection, etc. No change.

Testing:

If I change the trigger to "When an email is received" (in my primary email inbox), the Flow works fine. 

Final fix:

The Shared Mailbox has some rules setup that when an email is received with a certain Subject string, they are moved to a subfolder within the Inbox.

These are the emails I want to trigger my flow.

I had to manually type in the subfolder path (Inbox/subfolder) because selecting it from the folder picker did not work

Potential fixes:

I'm not sure what fixed it, but some combination of:

- Waiting for a day+ after being added as a member of the Shared Mailbox

- Recreating the Flow after being added as a member of the Shared Mailbox

- Adding a new Connection after being added as a member of the Shared Mailbox

- Manually typing the subfolder path into Folder field of trigger

image.png

Hope this helps!

 

View solution in original post

6 REPLIES 6
ChristianAbata
Super User
Super User

hi @ericonline  how many time passed after your team adds you to the mail box? some times you need to wait.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Now 24hrs has passed. Same error. Any further ideas?

 

{
  "status": 404,
  "message": "The specified object was not found in the store., The process failed to get the correct properties.\r\nclientRequestId: 1892edb1-63d2-49f6-92ff-f95d72096c33\r\nserviceRequestId: 0bef922e-b280-4e69-9004-4e217c286f00",
  "error": {
    "message": "The specified object was not found in the store., The process failed to get the correct properties."
  },
  "source": "office365-eus2.azconn-eus2-01.p.azurewebsites.net"
}

@ericonline  please try creating a new conector in a new flow.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Hi @ChristianAbata , a new connector, or a new connection?

If connector, I'm not sure what you mean. I will try to create a new connection to O365Outlook and see if that solves the issue.

@ericonline  yes sorry for my translation, please try re-creating your flow, new conection and new trigger etc..



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

@ChristianAbata ,

I created a new Flow, new trigger, connection, etc. No change.

Testing:

If I change the trigger to "When an email is received" (in my primary email inbox), the Flow works fine. 

Final fix:

The Shared Mailbox has some rules setup that when an email is received with a certain Subject string, they are moved to a subfolder within the Inbox.

These are the emails I want to trigger my flow.

I had to manually type in the subfolder path (Inbox/subfolder) because selecting it from the folder picker did not work

Potential fixes:

I'm not sure what fixed it, but some combination of:

- Waiting for a day+ after being added as a member of the Shared Mailbox

- Recreating the Flow after being added as a member of the Shared Mailbox

- Adding a new Connection after being added as a member of the Shared Mailbox

- Manually typing the subfolder path into Folder field of trigger

image.png

Hope this helps!

 

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,098)