cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Sharepoint 365 flow not populating non required dynamic fields

Looking for some SP help here. Before I begin I am trying to resolve this within SP 365 not via Sharepoint designer or infopaths if possible (as I don't have access to them).

I have created a "when an item is created or modified" flow which triggers an email when a drop down choice item is changed to a certain word.

 

The flow works, the email triggers fine and goes to the person who submitted the item to the list from the dynamic field "Requestor" (This is a required field when submitting the form).

 

However, I want to include within the email the assigned to name which is a people field available from the list. I want to use that same field to populate the email address so that the person who has submitted the list request gets the email as does the person selected in the assigned to box. Issue is, this is a field changed after submission therefore it is not a required field when the form is initially submitted.

 

Due to this, when the email is created it won't seem to populate from the assigned to field even if it has been filled in after the form was submitted and has a value.

 

This same issue happens with any non required fields available as dynamic. I am aware it does warn you when adding them it may fail as they are not required but they have values in when modifed so I'd like to know if there is a way to resolve this?

 

Many thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

Thanks for your response. Actually managed to resolve this. The issue was the people field was allowing multiple values so it wasn't poplating. Switched to single only and now it's fine.

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Hi @Anonymous,

 

Thanks for the feedback.

If the none-required field is needed in the Flow, we could add a condition to check whether this field contains value with the Empty () function.

For example:

@empty(triggerBody()?['AssignedTo']?['Email'])

20.PNG

The Empty() function would return true if the field has no value.

So if this field contains value, then we need to add action under the no part.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Thanks for your response. Actually managed to resolve this. The issue was the people field was allowing multiple values so it wasn't poplating. Switched to single only and now it's fine.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (10,055)