cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
virakones
Responsive Resident
Responsive Resident

Sharepoint Attachment flow shows up in Email but not Teams Approval Adaptive Card

Hi 

 

I'm a bit stumped and not able to find any documentation or users with similar issues.

 

I have a flow based on the "Request approval in Microsoft Teams when a SharePoint item is created" template. The item will be added from Powerapps and users can add attachments.

 

The only thing I've added to the template is that it will get the attachments and attachment content in an array variable and then I append to the variable the filename and content and then add it to the Array attachment on the Approval action.

 

From there an action to post an adaptive card in teams to a user will take that Approval and send it. 

 

Now the part I don't get, the flow works fine for attaching to email, which shows up for me as a flow owner, however, the Adaptive card doesn't show the Attachment? I'm a bit new here to Adaptive Cards and I'm unsure what went wrong.

Question: How do I show the attachment in the Adaptive Card in Teams that seems to be showing up properly in the email?

 

Below are some images.

Flow - get attachment array variableFlow - get attachment array variable

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Flow - Post adaptive cardFlow - Post adaptive card

 

 

 

 

 

 

 

 

 

 

 

 

 

Flow - Approval attachment array from variableFlow - Approval attachment array from variable

 

 

 

 

 

 

 

 

 

 

 

 

 

Email - Attachment thereEmail - Attachment there

 

 

 

 

 

 

Teams - Adaptive Card no attachmentTeams - Adaptive Card no attachment

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-alzhan-msft
Community Support
Community Support

Hi @virakones ,

 

I have made a test on my side and the issue is confirmed. I'm afraid that the function show the attachment of request in the Adaptive Card is not supported in Microsoft flow currently.

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
v-alzhan-msft
Community Support
Community Support

Hi @virakones ,

 

I have made a test on my side and the issue is confirmed. I'm afraid that the function show the attachment of request in the Adaptive Card is not supported in Microsoft flow currently.

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-alzhan-msft 

 

Bummer!

Thank for confirming - maybe I can suggest this to be added in the future .

BurakSahin
Regular Visitor

Hi, is there any update of this issue or workaround?

Helpful resources

Announcements
 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (1,562)