cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mhulse
Frequent Visitor

Sharepoint Email when Task not Completed

I'm working on this as part of a more complex Flow, but I don't understand why this part isn't working.

 

As far as I can tell this should only send an email if the Task is not marked Completed. But it is sending the email even if the Task is marked completed. 

 

I'm receiving an email for every task, when I should only be receiving emails for Tasks 1-4.

 

Inkedscreencapture-us-flow-microsoft-manage-environments-Default-170797d8-2df5-431b-99a1-c4f2160d543b-flows-1d9d313e-d91a-495c-8e44-957700eba8a2-2018-06-06-10_18_55_LI.jpgCapture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
v-yuazh-msft
Community Support
Community Support

Hi @ mhulse,

 

There is something wrong in your Condition.

 

Please refer to screenshot below to create the flow:

Capture.PNG

 

Note:

The "Task Status"  column is a choice type column, please choose the "Task Status Value" dynamic content in the first field of the Condition,and fill in value "Completed" in the Second field of the Condition.

 

Please let me know if your problem could be solved.

 

Regards,
Alice Zhang

View solution in original post

4 REPLIES 4
v-yuazh-msft
Community Support
Community Support

Hi @ mhulse,

 

There is something wrong in your Condition.

 

Please refer to screenshot below to create the flow:

Capture.PNG

 

Note:

The "Task Status"  column is a choice type column, please choose the "Task Status Value" dynamic content in the first field of the Condition,and fill in value "Completed" in the Second field of the Condition.

 

Please let me know if your problem could be solved.

 

Regards,
Alice Zhang

Thank you so much, that worked! I was so frustrated!

Markusr
Frequent Visitor

Hi guys,

 

I am working to replicate this flow, but apparently something was changed in handling the "assigned to" function, because its not working for me.

 

First my flow:

flowflow

 

The get items are working, those we verified with the output.

 

Here the error:

ExpressionEvaluationFailed. The execution of template action 'Apply_to_each_2' failed: the result of the evaluation of 'foreach' expression '@items('Apply_to_each')?['AssignedTo']' is of type 'Object'. The result must be a valid array.

error of the flowerror of the flow

 
 
Markusr
Frequent Visitor

I found the issue for me now.

The problem was, that my "assigned to" on the SharePoint list was disabled for "multiples". Therefore the error occured.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (3,644)