cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
oddbjornolsen
Frequent Visitor

Sharepoint Get items : 'The API operation 'GetItems' is missing required property 'body/value/8/Title'.'

Getting this error message on a seemingly simple use of the "Get items" actions;

The API 'sharepointonline' returned an invalid response for workflow operation 'Get_items' of type 'OpenApiConnection'. Error details: 'The API operation 'GetItems' is missing required property 'body/value/8/Title'.'

 

Filter Query : <Tekstfield> eq null 

Using top Count : 10 (while testing)

 

 

8 REPLIES 8
yashkamdar
Solution Sage
Solution Sage

Hello Team,

 

Your Filter query is incorrectly configured in the GET ITEMS action.

 

Can you please let me know the type of the Column <Tekstfield> is , is it a Text or Date or Choice type column ?

 

Awaiting response...

 

 

It is defined as Number. The intent of the flow is to use Update item further down in the flow to populate this field with a value based on an expression.

yashkamdar
Solution Sage
Solution Sage

Hello Team, This worked just fine for me and also returned the correct values for me, see below

 

 

yashkamdar_0-1600430557419.png

 

 

 

Capture.PNG

 

 

I think the issue you are facing is that you are not correctly passing in the name of your column.

 

Can you copy the Internal name of your column and pass that in the query. 

 

You can find the name of the column in the List settings -> Columns -> Click on the column

 

 

yashkamdar_1-1600430667524.png

 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Thank u for follow-up. The name is correct and to be on the safe side I now tried to remove the query and it still fails with the same error message.

 

As there is reference to Title in the error message I checked that it is there w/its standard field name and defined as required.

 

I had the same issue. Turns out I had a hidden column, that had been made mandatory, but which had no values it it. Once I took that off, the flow worked correctly.

kwas
Frequent Visitor

Solved a similar issue by

1. changing the Title field to Optional (from Required),

2. then rebuilt the Get Items step in Power Automate.

Here's the error message I received to start this adventure:

The API 'sharepointonline' returned an invalid response for workflow operation 'Get_items' of type 'OpenApiConnection'. Error details: 'The API operation 'GetItems' is missing required property 'body/value/2/Title'.'
Hope this helps someone.

This solved my issue. Thank you 🙂

ManiLive
Advocate I
Advocate I

Looks like Microsoft has fixed this issue with SharePoint - Get Items action.  I came across this issue recently with an old flow. 

 

When I created a new flow with the same action, the issue did not appear, even though I had a record with an empty Title value.

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Users online (2,926)