cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jbarkerag
Advocate II
Advocate II

Sharepoint List Item to Update Planner Task Progress

I have a SharePoint list that I am using to create and update Planner tasks. I have figured out how to get every field over to Planner except for the Progress field. I currently have a "choice" column name Progress in my list that has the options {'Not started', 'In progress', 'Completed'}. 

 

I am using the Dynamic content of "Progress Value" from my list to populate the task's Progress field, however it does not seem to be working. It always adds a value of "Not started", regardless of what is in the choice field.

 

Is this not the correct way to accomplish this? Does the task Progress field not accept text values?

 

Update Progress on Planner Task.png

1 ACCEPTED SOLUTION

Accepted Solutions
v-yuazh-msft
Community Support
Community Support

Hi @jbarkerag,

 

I have made a test on my side and don't have the issue that you mentioned,the task Progress field accept text values.

 

Could you please share a full screenshot of the configuration of your flow?

 

Please make sure the value of the "choice" column name Progress in your list that has the options 'Not started', 'In Progress', or 'Completed'.

 

The screenshot of the configuratopn of my flow as below:

Capture.PNG

 

The flow would run successfully as below:

Capture.PNG

 

Another screenshot of the flow as below:

Capture.PNG

 

The flow should should successfully as below:

 

Capture.PNG

 

 

 

Best regards,

Alice

 

View solution in original post

3 REPLIES 3
v-yuazh-msft
Community Support
Community Support

Hi @jbarkerag,

 

I have made a test on my side and don't have the issue that you mentioned,the task Progress field accept text values.

 

Could you please share a full screenshot of the configuration of your flow?

 

Please make sure the value of the "choice" column name Progress in your list that has the options 'Not started', 'In Progress', or 'Completed'.

 

The screenshot of the configuratopn of my flow as below:

Capture.PNG

 

The flow would run successfully as below:

Capture.PNG

 

Another screenshot of the flow as below:

Capture.PNG

 

The flow should should successfully as below:

 

Capture.PNG

 

 

 

Best regards,

Alice

 

View solution in original post

Hi @jbarkerag,

 

Have your problem be solved according to my solution? If yes, please go ahead and mark the post as solved by clicking “Accept as Solution” so that this thread will be marked for other users to easily identify!

 

Best Regards,

Alice

Hi Alice,

 

Sorry for just now responding. Thank you for pointing the capital P out to me. For what it's worth, I was just trying to mimic the displayed values directly from the Planner user interface.

 

Progress Options in Planner.png

 

But once I changed my values in the SharePoint list to "In Progress", it worked just fine. I think I'm going to submit a suggestion that they update the values to be consistent. Regardless, it was an easy fix, and thank you for your help!

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,591)