cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Sharepoint Sites Missing from Dropdown

I have a few of my Sharepoint sites that do not show up in flow when I have tried to do a number of flows involving them therefore I am not able to select a folder in those sites to create files in a flow.  About half of the sharepoint sites exist in the dropdown list.

 

I am attempting to create some simple flows such as saving email attachments and syncing 2 sharepoint folders.  

 

I have also attempted to use 'add custom value' and paste the link to the site in but that fails in validation when saving the flow.

 

I cannot find other solutions to this so far in the community.

 

Is there a setting somewhere that is affecting this?  These are templated flows and are quite simple.  Any help appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

I hired a consultant to help me with this and he was able to solve very quickly.

 

There was a special character in the site address.  it was an '

 

He recommended since there is no ability to change the URL to encode the ' with %27.

 

 

View solution in original post

16 REPLIES 16
Highlighted
Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

I experienced this with Survey List which is an older type of list.  It doesn't show up in the dropdown, but I was able to type in the list name.  After the list name is accepted, the fields on the list will show up. 

 

Hope this helps.

Highlighted
Community Support
Community Support

Re: Sharepoint Sites Missing from Dropdown

Hi jsia,

 

Do you have access to all the sites?


Are they sub sites under your site?


Please show me more details about your sites.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

I do have access, or should, as I created them all.  

They were created via Teams to create Team and Site.

 

 

I am able to add the sharepoint site as a custom value now I found and the corresponding folder paths are there which is a good sign but when updating/saving the flow I get this error.

 

The template validation failed: 'The template action 'Create_file_2' at line '1' and column '1783' is not valid: "The template language expression '/datasets/@{encodeURIComponent(encodeURIComponent('https://alliantpr.sharepoint.com/sites/Martin'sTeam'))}/files' is not valid: the string interpolation segment starting at position '10' is not terminated.  Make sure that ever '@{' is followed by its '}'.".'

Highlighted
Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

Still seeking answers as to the error I am receiving if anyone can help me with this.

 

Thanks,

 

Jon

Highlighted
Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

Can anyone help me with the error I am receiving when inputting the sharepoint site under custom value?

 

It allows me to find the fields I want after putting in the sharepoint site address, so it seems it recognizes it well, but when I go to save/update flow, the error happens.

Highlighted
Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

I hired a consultant to help me with this and he was able to solve very quickly.

 

There was a special character in the site address.  it was an '

 

He recommended since there is no ability to change the URL to encode the ' with %27.

 

 

View solution in original post

Highlighted
Community Support
Community Support

Re: Sharepoint Sites Missing from Dropdown


Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Regular Visitor

Re: Sharepoint Sites Missing from Dropdown

I have similar issue.  The drop down does not show the site and the site link does not have any special characters.  I am in Office 365 A1 Plus and have access to Microsoft Forms (Plan2 ) and SharePoint Plan 1 for EDU as an admin.

First I created an Office 365 Form and collected 1st set of data.  Then I created a Sharepoint list store the Form results.  Now I am trying to create a flow, and I can't find the SharePoint site.  I can't type it either.

Any and all suggestions are appreciated.

 

Highlighted
Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

I found copy/pasting from the share point site itself was the best.  

 

I found some very good and affordable help for troubleshooting this stuff on Upwork.com.

Highlighted
Regular Visitor

Re: Sharepoint Sites Missing from Dropdown

I'll visit Upwork.com.  Thank you jsia.  I couldn't copy/paste because that's not an option for me.   I see two choices "No Items" and "Enter custom value" in my drop-down menu.  I choose "Enter custom value " and I still can't type the SharePoint site address.

Highlighted
Anonymous
Not applicable

Re: Sharepoint Sites Missing from Dropdown

I have the same iissue. Microsoft Flow don't suggest a new site a have created. I also cannot type the address.
Any solution to fix it? 
seem like Microsoft Flow have a lot bugs

Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

I got some help on this issue.  Some sites won't show but I also couldn't type in the name of the site at that time (which should work) because i had some punctuation issues.  See the link for the solution I found.

 

https://powerusers.microsoft.com/t5/Using-Flows/Sharepoint-Site-missing-from-flow/m-p/66297#M1976

Highlighted
Advocate I
Advocate I

Re: Sharepoint Sites Missing from Dropdown

Can you provicde some insite on how you solved this? I am using a different user / connection to do the Sharepoint update item and while this user can access said SP site using the browser URL when entering manually into a Flow it doesnt validate when saving.  The link you pointed to only discusses about manually entering the SP site URL to avoid any weird characters but this doesnt appear to have worked.

 

Thanks,

 

Alex

Highlighted
Regular Visitor

Re: Sharepoint Sites Missing from Dropdown

I am having the same problem.  There are no special characters in the URL.

Highlighted
New Member

Re: Sharepoint Sites Missing from Dropdown

Oh man this saved me! I was about to lose my mind. 

Highlighted
Regular Visitor

Re: Sharepoint Sites Missing from Dropdown

It worked for me !

 

Not a very permanent fix, but it'll help you move on.

 

Save your flow as a new one and then try using the site url in the dropdown (Enter custom value).

 

Hope it helps.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (6,374)