cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Serbay
Advocate II
Advocate II

Sharing Office Scripts Issue

Hi All, 
Has anyone faced an issue with sharing Office Scripts to be used in flows for other users?
There is an issue, for users who have access to the flows, files and scripts can not execute the script in flows. 
Error: Script not found. It may been unshared or deleted

 

Any idea?

 

Regards,
Serbay

9 REPLIES 9
Expiscornovus
Super User II
Super User II

Hi @Serbay,

 

Can you double check if the specific scripts are enabled for sharing?

https://support.microsoft.com/en-us/office/sharing-office-scripts-in-excel-for-the-web-226eddbc-3a44...

 

 

Serbay
Advocate II
Advocate II

Yes, I have seen some others facing this issue last week.
All file access given, flows and scripts shared, still receiving an error.

Expiscornovus
Super User II
Super User II

Hi @Serbay,

 

I am able to reproduce it, so it feels like we are missing something. Or it is a bug 😁

 

Do the other people see the script listed under the This Workbook section of the Office scripts?

testscript.png

 

And what happens when they run it manually. Do the get the Run Permission question and does that work?

runpermission.png

 

Also the sharing on the Office Script looks ok. It is still hosted in the OneDrive of the original owner.

officescripts_osts.png

Serbay
Advocate II
Advocate II

Yes, I can see that script has been shared with the user, even I have checked on his account, It can be seen after sharing the script.
When it comes to running the flow that I have created and shared with the user. The script is not executing, basically giving an error as not found, not shared or deleted.


Yes, I have tried to run manually, It asks for permission, and I'm allowing it. But not running the script. When I click the run permission again, it keeps asking me to allow or deny but no executing the script. 
The script runs normally by me but not for a user.

Serbay
Advocate II
Advocate II

I will try to create all scripts again then share them.
Regards,
Serbay

Serbay
Advocate II
Advocate II

Update
A user created a new script and shared it with me, I was able to run the script after clicking allow button.
But, When I create a script and shared it with the user, the user was not able to run a script after clicking allow button.
How this could be possible?

 

Thanks a lot for your answers by the way!
Regards,
Serbay

Expiscornovus
Super User II
Super User II

Hi @Serbay,

 

I just noticed a new response in that other thread. Over there it is suggested to change the setting for connections used. I have changed that an it was working for me now.

 

https://powerusers.microsoft.com/t5/Building-Flows/Office-Script-Error-quot-Script-not-found-It-may-...

 

Serbay
Advocate II
Advocate II

Hi,
Thank you so much for your response! But, unfortunately, this option is not available for flows that have a Power apps trigger.
Do you have any other ideas on how to call such a flow only on the behalf of the owner? 


Best Regards,
Serbay

Yutao
Microsoft
Microsoft

FYI, I've updated my answer to the linked post with a solution that works for me for the PowerApps trigger: https://powerusers.microsoft.com/t5/Building-Flows/Office-Script-Error-quot-Script-not-found-It-may-...

 

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (74,397)