cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ahowes
Helper I
Helper I

Simple? Trigger and copy item to another list flow not working

Hi all-

My first time building a trigger-filtered flow. I have a calculated yes/no field that successfully changes to yes when conditions are met in a new entry to a list.

I built the trigger @equals(triggerBody()?['RunAutomation'],true and then a create new item step going to the destination list. It does not seem to run even when the RunAutomation field shows YES. 

Everything else in the Trigger settings fields was left at the default.

I'd include a screenshot, but cannot figure out how to insert the image.

Thanks!

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi @ahowes,

 

I tried to reproduce your Flow, created a yes/no column named "NeedAdditionalTeam", and set condition in the "When an item is created or modified" trigger, and it works correctly:

Annotation 2020-05-04 150709.png

 

Annotation 2020-05-04 150722.pngAnnotation 2020-05-04 150518.png

 

And I also tried "When an item is created" trigger, it could work, too.

 

I assume the reason for the Flow not fired is caused by the column name not correct, if a column's name was modified, the column's system name wouldn't be changed. When you use it, it should be a system name, you could check its system name in the column detail page and extract it from URL:

Annotation 2020-05-04 151412.png

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

@v-litu-msft @abm , thanks so much for your help! 

 

Here is what solved the issue...makes no sense to me, but it worked 🙂


My typo was in my post here, not in the workings of my workflow or the column name, so that wasn't the issue. I was using the correct column name in all of the workflows I attempted and even tried yet another new column. Still didn't work.

 

Solution:

I eliminated the column from the list. I built another new yes/no column named "AdditionalTeam". I deleted my previous workflows and started from scratch, except this time, I created a new one from a blank flow in Power Automate, rather than from the Power Automate button at the top of the SharePoint list. Makes no sense, but I'm not going to question it.

I used the exact statement from above except for changing the column name to "AdditionalTeam". It fired off just fine.

 

I very much appreciate the time you took out of your weekend to help!

View solution in original post

13 REPLIES 13
abm
Super User
Super User

Hi @ahowes 

 

You are missing a bracket here for your expression

 

@equals(triggerBody()?['RunAutomation'],true

 

change to

 

@equals(triggerBody()?['RunAutomation'],true)

 

May I ask you what's your trigger is (SharePoint item created or modified?) then it should be

 

triggerOutputs()?['RunAutomation']

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Oops. That is only missing in my post above. It is present in my workflow and is still not working. I just got to thinking that perhaps it's because I'm using a calculated column and the value isn't present when submitted. I'm going to try to use a non-calculated column and see what happens...

I added a non-calculated field and it still does not trigger 😞

 

Ok.........I don't have anything that is:

"May I ask you what's your trigger is (SharePoint item created or modified?) then it should be

triggerOutputs()?['RunAutomation']"
Which means I probably am not outputting anything from the trigger? Where would triggerOutputs()?['RunAutomation'] go?
Thanks!

Hi @ahowes 

 

I have added a compose after the trigger and looked the peek code. It did showed ' triggerOutputs()?['RunAutomation'].  I thought  triggerBody()?['RunAutomation'] should have worked.

 

You need to set this under the settings > Trigger Condition

 

Please have a look at this.

https://www.youtube.com/watch?v=j-gP-E6CCE4

 

Thanks

 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

I am completely baffled. As I said, I built a new field to eliminate the potential that my calculated field (RunAutomation) was the problem. The new field "NeedAdditionalMeeting" is a manual yes/no. Per my original thought, your instruction AND the YouTube video you linked, I have it exactly as it should be (I think):

@equals(triggerBody()?['NeedAdditionalTeam'],true)

 

I also tried, since I'm grasping at straws at this point, and because I'm brand new and don't know any better:

@equals(triggerOutputs()?['RunAutomation'],true)

 

It still will not run. Everything else in the "when an item is created or modified" trigger is as it appears when first opened. I only added the statement above. This is frustrating! (But I guess if it were easy a lesser person would have my job 🙂 )

Oops. I typed wrong above. The field is "NeedAdditionalTeam". My statement matches the field, I just typed it wrong in my text above. Thanks.

Hi @ahowes 

 

Thanks for your update.

 

If you happy with the response and found the solution please accept it as solution accepted. It will help others in community when they looking for solutions.

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

I even just rebuilt it from scratch just to see if something was corrupted in the original.

@equals(triggerBody()?['NeedAdditionalTeam'],true) still gets no triggered workflow 😞

Hi @ahowes 

 

Thanks for the update.

 

Try 

 

@equals(bool(triggerBody()?['NeedAdditionalTeam']),true)

 

 

 



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

Well, at least I got an error that time! Nothing at all happened before...

InvalidTemplate. Unable to process template language expressions for trigger 'When_an_item_is_created_or_modified' at line '1' and column '4336': 'The template language function 'bool' was invoked with a parameter that is not valid. The value cannot be converted to the target type.'.

Hi @ahowes,

 

I tried to reproduce your Flow, created a yes/no column named "NeedAdditionalTeam", and set condition in the "When an item is created or modified" trigger, and it works correctly:

Annotation 2020-05-04 150709.png

 

Annotation 2020-05-04 150722.pngAnnotation 2020-05-04 150518.png

 

And I also tried "When an item is created" trigger, it could work, too.

 

I assume the reason for the Flow not fired is caused by the column name not correct, if a column's name was modified, the column's system name wouldn't be changed. When you use it, it should be a system name, you could check its system name in the column detail page and extract it from URL:

Annotation 2020-05-04 151412.png

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

@v-litu-msft @abm , thanks so much for your help! 

 

Here is what solved the issue...makes no sense to me, but it worked 🙂


My typo was in my post here, not in the workings of my workflow or the column name, so that wasn't the issue. I was using the correct column name in all of the workflows I attempted and even tried yet another new column. Still didn't work.

 

Solution:

I eliminated the column from the list. I built another new yes/no column named "AdditionalTeam". I deleted my previous workflows and started from scratch, except this time, I created a new one from a blank flow in Power Automate, rather than from the Power Automate button at the top of the SharePoint list. Makes no sense, but I'm not going to question it.

I used the exact statement from above except for changing the column name to "AdditionalTeam". It fired off just fine.

 

I very much appreciate the time you took out of your weekend to help!

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (2,337)