cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dsalad
New Member

Simple add row to excel when task complete; succeeds but no new row in file

Can't figure out why Flow isn't adding a row to my excel table. This is a simple recipe...Where else can I look? THANK YOU!

Flow recipeFlow recipe2success.png3File.png4nothingthere.png5TableSetup.png

3 REPLIES 3
v-bacao-msft
Community Support
Community Support

Hi @dsalad ,

 

It seems that there is no problem with the configuration of Flow.

First make sure that the table you are configuring is the one you expect.

In addition, I noticed that Excel table seems to have only one row (I mean Excel table instead of the current sheet).

When you use "Format as Table" to select the selected cell as a table, the number of rows selected is the current number of rows in the Excel table.

Try the following method to add more rows to store information about the task.

Image reference:

444.gif

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I have tried several table sizes. The example I sent had one row, but I have tried multiple row tables, single column tables, etc. What is even more odd is that it has done seomthing a couple of time, but never when I am watching. I have opened the excel sheet and found a couple rows inserted...not sure who completed the task, but there were rows. I did what you suggested and the flow showed successful, but no rows were inserted/added.

 

I'm perpelexed and frustrated. Multiple tests this morning with different configurations did not work.

 

I'm starting to wonder if it is my permissions, OR that my tet tasks have been completed once and I am "uncompleting" them and then clicking complete to do my testing. I have tried completing other people's tasks and it doesn't work. Maybe it is a permissions issue or a connector issue (even thought all my connectors show green). 

 

 

Hi @dsalad ,

 

I am sorry that you have encountered such a situation.

Could you share screenshots of Flow run history? I did a test on my side and it seems to be able to reproduce a similar issue.

Whether your Flow run history is the following situation, although the Flow display runs successfully, but the action in Apply to each is not executed, so the expected row is not added in the Excel table.

13.PNG

If the situation is the same as above, the solution is to ensure that the task that is currently complete is assigned to the specific user.

14.PNG

If there is no similar operation, then assignments will be an empty set, so Apply to each will not traverse any values.

Please take a try again and feel free let me know if issue still exist.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (3,193)