cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Simple flow in SP list fails after 100 items, but runs all items

 

 

Hi people

 

I'm at a loss and I've dried out Google and this forum for a solution.

 

I get this error and a failed flow at list item 101 - it runs smoothly from 1 to 100:

flow1.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Now the flow i run on a SharePoint list with about 4000 items and set to recur every day at midnight.

 

Get items:
flow2.png

 

 

 

 

 

 

 

 

 

 

 

I have tried turning on pagination, but then it just gives me a pagination error straight away with an error, that says, that the NextLink is bad. Leaving pagination off and setting the top count is the only way to get it to run beyond the first 100 items.

 

There is a filter in the get items, which filters out items with irrelevant statusses.

 

After the get items, which seems to run without incident, the flow goes to the Apply to each with a condition:

flow3.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Why can't I get this to run?

 

My reason for making this flow is to delete GDPR sensitive information in the list items, when the list item hasn't been modified for a year and if the item doesn't have either of the two statusses in the filter and in the condition (reason for repeat is my insecurity and because I somehow deleted information on the first 100 items, that shouldn't have been removed - I simply left the fields empty in the 'update item', which shoudn't have deleted anything!?).

 

I am hoping you smart people can lead me in the right direction!

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Frequent Visitor

Re: Simple flow in SP list fails after 100 items, but runs all items

Oh, and the filter, which is supposed to filter out the items, which have been modified within the last year goes:

addDays(item()?['Modified'], 365, 'yyyy-MM-dd') is less than utcNow()

View solution in original post

3 REPLIES 3
Highlighted
Frequent Visitor

Re: Simple flow in SP list fails after 100 items, but runs all items

Oh, and the filter, which is supposed to filter out the items, which have been modified within the last year goes:

addDays(item()?['Modified'], 365, 'yyyy-MM-dd') is less than utcNow()

View solution in original post

Highlighted
Community Support
Community Support

Re: Simple flow in SP list fails after 100 items, but runs all items

Hi @Kvist80 ,

 

From the error message of Apply to each 2, it seems that there is an error on the function you are using.

 

What’s the function being used at here?

 

I have made a flow which is simply configured likes below. The error message you’ve mentioned doesn’t occur.

1.PNG

 

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Simple flow in SP list fails after 100 items, but runs all items

Thank you - I just had to remove the Apply to each 2 and now it works. Thank you so much!!

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,043)