cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
esuna114
Frequent Visitor

Simple salesforce azure devops connection not working

Hello all, I have an unkown issue when trying to update a custom record from salesforce, do you have any idea? I filled all fields but this seems to always send back the same issue independent on how the fields are filled, could you let me know if you have any idea? Thanks

 

esuna114_0-1593984414846.png

 

3 REPLIES 3
v-litu-msft
Community Support
Community Support

Hi @esuna114,

 

Could you please share the setting of the Update record action?

Maybe you could recreate the connection of the Salesforce and try it again.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello @v-litu-msft thanks, I already deleted and recreated the connection, as well as changed fields to see if something is happening. Please note that the SF connection itself is working perfectly fine in my other flows, with other triggers or actions.

 

Here's the setup (Images + peek view)

 

esuna114_0-1594020540006.pngesuna114_1-1594020580526.png

 

 

{
    "inputs": {
        "host": {
            "connection": {
                "name": "@parameters('$connections')['shared_salesforce_1']['connectionId']"
            }
        },
        "method": "patch",
        "body": {
            "Category__c": "Sales Support",
            "Expertize_Needed__c": [
                "Platform"
            ],
            "Priority__c": "Low",
            "Division_TRR__c": "EMEA",
            "Industry_Segment__c": "Non-TAM",
            "OwnerId": "0053600000350MIAAY",
            "CurrencyIsoCode": "AUD",
            "Account_Type__c": "Territory",
            "Additional_Comments__c": "@triggerBody()?['fields']?['Custom_Additionalcomments']",
            "Case__c": "Test PLEASE IGNORE",
            "Deliverables__c": "Test PLEASE IGNORE",
            "Description__c": "test",
            "Estimated_Hours__c": 0,
            "Expected_Completion_Date__c": "Test PLEASE IGNORE",
            "Lead__c": "Test PLEASE IGNORE",
            "Notes__c": "Test PLEASE IGNORE",
            "Reason_for_High_Priority__c": "Test PLEASE IGNORE",
            "Status__c": "Closed",
            "Subject__c": "Test PLEASE IGNORE",
            "Suggested_Engineer__c": "Test PLEASE IGNORE",
            "Sub_Category__c": "Other"
        },
        "path": "/v2/datasets/default/tables/@{encodeURIComponent(encodeURIComponent('Technical_Resource_Requests__c'))}/items/@{encodeURIComponent(encodeURIComponent(triggerBody()?['fields']?['Custom_SalesforceId']))}",
        "queries": {
            "$select": "Additional_Comments__c"
        },
        "authentication": "@parameters('$authentication')"
    },
    "metadata": {
        "flowSystemMetadata": {
            "swaggerOperationId": "PatchItem_V2"
        }
    }
}

 

EDIT: Same issue by completely recreating the flow.

 

Hello, is thatere a way to make an official bug report? I really need an answer. Thanks

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (1,742)