cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
solstice
Advocate I
Advocate I

Something broken with Create File Action - Status 400 / Bad Request / Bad Gateway

We have noticed that since Wednesday all our flows are starting to fail which have utilized the "Create File" Connector. 

They have been running fine over the last 6+ month and are now failing with a "Error in the application" error / Bad Request. 

We have also tested it with creating a new sample flow just for this case and it has the same error message: 

solstice_0-1632456898452.png

 

Anyone know if microsoft has done some updates to the sharepoint actions that may have broken this?

 

S.

 

 

11 REPLIES 11
eric-cheng
Solution Sage
Solution Sage

Hi @solstice ,

 

Just tried and was able to create the file successfully but I guess it could be region specific.

 

ericcheng_0-1632470919598.png

 

I know you said you created another flow but have you tried another library?

 

Can you also share what parameters are passed int the Create File action?

 

--------------------------------------------------------------------------
If I have answered your question, please mark my post as a solution
If you have found my response helpful, please give it a thumbs up

Connect on LinkedIn

Hi Eric, 

I have tried different libraries, different site collection even and as well different "Flow Environment", with the same outcome. 

As per parameters, it is very basic for this test as well: 

solstice_0-1632493741783.png

The Create File "File Content" comes from a valid file in "Get file Content".

 

The settings on the Action (default):

solstice_1-1632493967969.png

 

 

Sascha

 

 

Ponnusamy
Advocate I
Advocate I

I am having the same issue, it's started happening from yesterday (9/25/21) and my location is US East.

MDBirchett
Regular Visitor

I am also having the same issue. It was first noticed today (9/27/2021). My location is also eastern US.

LukeAtWork
Frequent Visitor

I have the same issue, it seems to only happen when you create file in a document set

https://powerusers.microsoft.com/t5/Building-Flows/Create-File-operation-in-document-set-no-longer-w...

I do not have Document Sets enabled and I still have the error.

solstice
Advocate I
Advocate I

After working tirelessly with some support staff at microsoft, check if your create file action is set to allow chunking or not. If so, try disable chunking and try again. 

That worked. Thank you for sharing that.

@solstice : That worked. 

 

Everyone,   FYI, in my case the file was created successfully and still the flow failed with 400  error. I would assume you all had the same issue. It looks like some release behind the scenes created this issue,  not sure what exactly caused it.

Yes. The file was created but the flow failed.

ZERAREZ
New Member

I'm still having the create file issue resulting to a corrupted file even after turning of the chunking: 

ZERAREZ_0-1633722005645.png

Is there another fix? Also tried the Base64tobinary but it has flow null error

 

Appreciate any help,

 

Neil

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (866)