cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Specified folder not found Error

Hi All,

i am trying to run a simple workflow where in i am creating an excel file on sharepoint document library and sending that as an attachment through the mail. 
i am using "Send email from shared mailbox" and when ever i try to run the flow it works fine , however when any other user runs the flow it gives the error.

i have another workflow that uses the same action but it does not fail. Also, the flow which fails is initiated through Powerapps.

{
  "status": 404,
  "message": "Specified folder not found.\r\nclientRequestId: a9682066-eb71-4a0d-859a-cd50b21feb64\r\nserviceRequestId: 88f09eb7-56d7-4e88-a0be-2892c85dd290",
  "error": {
    "message": "Specified folder not found.",
    "code": "ErrorFolderNotFound",
    "originalMessage": "The specified folder could not be found in the store."
  },
  "source": "office365-eus.azconn-eus-01.p.azurewebsites.net"
}

 

can any help me figure out what is the issue? Here is a screenshot of flow below
image.png

3 REPLIES 3
v-litu-msft
Community Support
Community Support

Hi @Anonymous,

 

When other users use the same action, their email account should have permission to access the mailbox for this operation to succeed.

So, please make sure they have permission to access the shared mailbox, and try it again.

For more information about shared mailbox, you could refer to this document:

https://docs.microsoft.com/en-us/exchange/collaboration/shared-mailboxes/shared-mailboxes?view=exchserver-2019

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Anonymous
Not applicable

@v-litu-msft so i have another workflow that uses the same shared mailbox to send the email, but it is triggered when a new item is created in sharepoint. 
However , the workflow that fails is the one which has Power apps as the trigger. 

 

Does that make any difference?

Anonymous
Not applicable

i could not find out the solution for this issue , so i changed the workflow send email action from "Send an email from Shared Mailbox" to "send an email" and that worked perfectly without any error.

 

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,294)