cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate IV
Advocate IV

Split string on '@'

Hi, 

 

Is there any decent way to split a string on @ ('at') in the Compose action?

 

What doesn't work:

  • split(string,'@'), the @ gets stripped out
  • split(string,"@"), the @ gets stripped out
  • ... working with / is not valid

 

I got it working by putting the @ in a seperate variable, but I do not like that solution that much.

 

Any idea?

 

Thx, 

Glenda

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Split string on '@'

Hi @Glenda,

 

Could you please share a screenshot of your “Compose” action’s configuration?

The split() function splits string based on specific separator and the separator doesn’t exist in output that the function returns.

I have made a test on my side and the flow works well. My flow’s configuration as below:12.JPG

 The flow works successfully as below:13.JPG

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Split string on '@'

Hi @Glenda,

 

Could you please share a screenshot of your “Compose” action’s configuration?

The split() function splits string based on specific separator and the separator doesn’t exist in output that the function returns.

I have made a test on my side and the flow works well. My flow’s configuration as below:12.JPG

 The flow works successfully as below:13.JPG

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Advocate IV
Advocate IV

Re: Split string on '@'

Hi Kris, 

 

I checked again today, seems to be working now without using the variable.

 

Overview of that part of my flow:

extguest1.PNG

The configuration of my Compose action is as follows:

last(split(body('Parse_JSON_-_external_guest')?['DisplayName'],'@'))

Seems to be that the "Update" button on my end sometimes does not function correctly in the expression builder. Got it working by clearing the expression completely and pasting it in again as the string defined above, it worked. Today is a better day... 🙂

 

Thanks!

 

Glenda

Highlighted
Regular Visitor

Re: Split string on '@'

worked for me.

 

Thanks

Helpful resources

Announcements
secondImage

August 2020 CYST Winners!

Check out the winners of the recent 'Can You Solve These?' community challenge!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (3,705)