cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Murderbot
Advocate III
Advocate III

Start and wait for an Approval (V2) error

I am testing response options in 'Start and wait for an Approval (V2)'  and am getting this error:

 

BadRequest. The request failed. Error code: 'InvalidRequestContent'. Error Message: 'The request content was invalid and could not be deserialized: 'Error converting value "[ "Alan","Alexa","Amy","Christina","Erin ","Justin ","Moriah ","Nicole ", "Horse" ]" to type 'System.String[]'. Path 'responseOptions', line 1, position 660.'.'.

 

I am pulling names from a Sharepoint group and appending them to a string variable.  I then put the string variable in as the Response Option as below:

image.png 

 

I have to add "Horse" to the end of the response options to use up the extra comma at the end of my string variable and meet the syntax requirement.  I tried to remove the extra comma using replace(variable('test'),substring(LastIndexOf(variable('test'),','),1),',','') with no success.  It woudn't see the comma, despite several variations.

 

The Approval works fine if I do not use dynamic content. I believe my syntax is correct, so I'm not sure why the flow continues to fail.  

 

Thanks for your assistance!

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @Murderbot 

 

First of all, try converting your "test" variable to type array rather than string, and then append each new string to the array using the append to array action.

Once you've done that, remove the [ ] from the response options. The field is expecting a type of array, so I think that's what is causing your issue.

Have a look at my attached screenshot, it's a little less complex than yours but still achieves the same goal.

FlowArray.PNG





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

View solution in original post

2 REPLIES 2

Hi @Murderbot 

 

First of all, try converting your "test" variable to type array rather than string, and then append each new string to the array using the append to array action.

Once you've done that, remove the [ ] from the response options. The field is expecting a type of array, so I think that's what is causing your issue.

Have a look at my attached screenshot, it's a little less complex than yours but still achieves the same goal.

FlowArray.PNG





Did my reply help? Please give it a thumbs up.
Did I answer your question? Please mark my post as a solution!
If you liked my response, please consider giving it a thumbs up. THANKS!


Proud to be a Flownaut!





Community Leader: Black Country PowerApps & Flow User Group

View solution in original post

Worked!  Many thanks for both the array var and bracket removal suggestions.

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Users online (50,063)