cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Status 400 Specified User could not be found - only impacts one user

 

 

I have a flow where a user submits a form via Microsoft Forms and then the results are saved in Sharepoint. My flow pulls in additional information that is preloaded to another sharepoint list by user. Essentially, my flow looks at who submitted the form and then pulls information into the Sharepoint item based on the submitter matching the user listed in the other sharepoint list. We have used this for about a year and haven't had any problems but I recently began having an issue where a single user cannot be found. The flow has and continues to work for all other users.

 

This user submitted a form late June and it worked but the form she submitted this past week did not work. I went a resubmitted the flow that worked in June and it is no longer working either. Here is the error we are receiving:

 

 "status": 400,
  "message": "The specified user Jones, Kimberly could not be found.\r\nclientRequestId: cd1189c3-d6ee-457a-bc30-799d894d7263\r\nserviceRequestId: cd1189c3-d6ee-457a-bc30-799d894d7263"

 

While the error is saying the user cannot be found, you can see that it is finding the correct user and attempting to pull in the appropriate fields. This user is item number 49 in the Sharepoint list and line 49 is where the flow is failing so it is seeing there is a match. However, it is still failing due to no user found. Below are screenshots of the flow as well as the audit of the failure.

 

Capture 1a.JPG

 

Capture 1b.JPG

 

Capture 1c.JPG

 

Capture 1d.JPG

 

Capture 1.JPG

 

Capture 2.JPG

 

Capture 3.JPG

 

6 REPLIES 6
Highlighted
Community Support
Community Support

Hi @kels89 ,

 

It seems that Flow configuration is fine.

Please try using Mail to configure User Profile Claims instead of Display Name.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted

@v-bacao-msft I do not hae  user profile claims option for this condition. Any thoughts on how to ge **bleep**? I have tried both mail and display name and neither is working but I'm happy to try this as well.

 

Capture 2a.JPGCapture 2b.JPGCapture 2c.JPGCapture 2d.JPGCapture 2e.JPG

 

Highlighted

@kels89 : I am having similar issue, were you able to resolve the issue?

Highlighted
Advocate I
Advocate I

I am having a similar issue and wondered if this ever was resolved?

Highlighted

@Axford_Clare I noticed that it was happening when there were multiple users with the same display name. On using email instead of display name it resolved the issue as search for users was returning only 1 user in that case. Other way of resolving it could be by using top 1 with display name to just pick the first user that is being returned. 

Highlighted

What fixed it for me was changing the Display name to UPN.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Top Kudoed Authors
Users online (12,578)