cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
syb03
Frequent Visitor

Step "Apply to each"

Hi,

 

I have built a flow which works fine until dynamic content is added to the last step "Send an email".

After I have added something from the Dynamic content list to the "Send an email" step, a new step "Apply to each" (with output "value") appears before the step "Send an email".

See also the screenprint below...

After this automated action, the flow does not work anymore.

I have searched for a solution, but no idea how to solve this.

Hope anybody can help.

Thanks

syb03_0-1663329170467.png

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
syb03
Frequent Visitor

Thank you… I used now a template which works fine. 

View solution in original post

2 REPLIES 2
Expiscornovus
Super User
Super User

Hi @syb03,

 

You could add the title of the first item of the Get items as an expression. This will prevent the flow from adding an apply to each action.

 

Use something like below:

body('Get_Items')['value'][0]['Title']

 

expression_onboarding.png



Happy to help out! 🙂

Interested in more #PowerAutomate #SharePointOnline or #PowerVirtualAgents content?
Visit my blog, Subscribe to my YouTube channel or Follow me on Twitter


syb03
Frequent Visitor

Thank you… I used now a template which works fine. 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Users online (1,682)