cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Struggling with Get File Content

I have a simple flow setup to email myself the content of a file when I create or modify a file in my sharepoint test site. When I add a file or modify a file in my site, the flow does not trigger. I have no idea why it's not being triggered. Any help would be appreciated.

 

 

Capture.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Struggling with Get File Content

Hi @the_joey_o,

 

I have made a test on my side and the flow triggers well. My flow's configuration as below:12.JPG

 

The flow works successfully as below:13.JPG

Please check if you have specified proper Site Address within Site Address field of the trigger, the standard format of Site Address as below:

https://contoso.sharepoint.com/sites/sitename

We could not type the File Content dynamic content within Body field of "Send an email" action directly, otherwise, it would cause a Bad Request error:15.JPG

 

 

 

In addition, the File Content dynamic content of "Get file content" action would return a binary text representation of the file, there is no way to analyze the binary content within Microsoft Flow currently, so the file content would show up as a binary representation within Body of the email, which starts with 'PK':14.JPG

 

 

 

Best regards,

Kris

 

 

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
Highlighted
Community Support
Community Support

Re: Struggling with Get File Content

Hi @the_joey_o,

 

I have made a test on my side and the flow triggers well. My flow's configuration as below:12.JPG

 

The flow works successfully as below:13.JPG

Please check if you have specified proper Site Address within Site Address field of the trigger, the standard format of Site Address as below:

https://contoso.sharepoint.com/sites/sitename

We could not type the File Content dynamic content within Body field of "Send an email" action directly, otherwise, it would cause a Bad Request error:15.JPG

 

 

 

In addition, the File Content dynamic content of "Get file content" action would return a binary text representation of the file, there is no way to analyze the binary content within Microsoft Flow currently, so the file content would show up as a binary representation within Body of the email, which starts with 'PK':14.JPG

 

 

 

Best regards,

Kris

 

 

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (8,352)