cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Survey123 dynamic fields missing

I have a Survey123 that I am putting in a flow to insert a new row into google documents.  The flow is working correctly.  The problem is when I go to add my fields from the survey some are missing.  The 3 that I'm looking for all pretain to an Other drop box.  Meaning that the end user had a drop down (field a ) with Other being one of the options.  When Other is selected they are than provided a text box (field b) to type in the Other info.  On the dynamic content I can see field a, but cannot see field b.  So when I send the data to the google docs the reviewer just sees Other, but never gets the other info because I cannot add field b as another field to transfer data.  I have 4 occurrences of this in my form.  Is there a reason these fields are not showing up?

4 REPLIES 4
Highlighted
Microsoft
Microsoft

Re: Survey123 dynamic fields missing

Hi,

 

Looking through this issue. I am not certain as to what is causing this. It initially seems like this is not supported but I don't see exactly what you would be hitting. This might be a better question for the Microsoft Support team. I'll include a link on creating a ticket with them if you would like to go down that route. Otherwise if any other communities members might know what is causing this, feel free to chime in.

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
New Member

Re: Survey123 dynamic fields missing

We are also having this issue. We created Flows connecting Survey123 and Google Sheets to add a new row on submission. When they were created, all of the dynamic content fields showed up. Now only the default ones (for Survey123) are appearing, but none of the custom dynamic fields. Same thing is happening with another Flow with Survey123 to send an email out on submit. 

Highlighted
New Member

Re: Survey123 dynamic fields missing

I could never find a real answer to this and only found it as a common problem as I found other posts on it.  My workaround is that I manually typed the trigger even in the expression box for those fields that didn't show up in my dynamic content.

 

This is an example of one of my expressions. Sewer_issue_other is the name of my field.

triggerBody()?['feature']?['attributes']?['sewer_issue_other']

 

Highlighted
New Member

Re: Survey123 dynamic fields missing

Hi! Thanks for the reply. We launched the project yesterday that was using this, so it has been a busy 24 hours. I actually found the same workaround. It's the only thing that seems to be working. I saw another person with the same issue writing on the ESRI chat board that was using a concat expression, but that wasn't necessary. Anyway, thanks for responding! Sorry I didn't reply to my own message before now giving the solution. 

Helpful resources

Announcements
secondImage

August 2020 CYST Winners!

Check out the winners of the recent 'Can You Solve These?' community challenge!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (4,880)