cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mrpowergage
Resolver I
Resolver I

Systemuser does not exist

I am building a flow to get a record when a user posts a message:

Screenshot 2020-03-14 at 09.48.16.png

 

I'm getting the error: systemuser With Id = 7a61d448-27a6-xxxx-xxxx-80e0aecb1471 Does Not Exist

 

Item identifier is :@{triggerBody()?['from']?['user']?['id']}

 

I suspect this is a permissions issue as I am the user posting the message to test the flow. 

 

It is built as a Team Flow in the default environment, I get the same issue if I build it on the production environment as a user flow. I have also tried building it on the solution, but it then doesn't trigger when a message is posted (it did let me select the team and channel when building the flow). All connections appear to be working fine.

 

Any help appreciated, thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks @efialttes 

 

Helpful prompt. The issue was that the Teams user is different from the Dynamics user. I used the Office365 Get User Profile, to get the email which I then matched to the Dynamics record.

View solution in original post

3 REPLIES 3
efialttes
Super User
Super User

Hi!
Just for doublechecking purposes, I would try to temporary add 'List records' so you can verify:
-if you have permissions to access the list
-if records IDs format are the same as user id from Teams
Since you're the one posting the message you can play with 'List records' 'Filter Query' input and try to get your record this way
Hope this helps


Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Thanks @efialttes 

 

Helpful prompt. The issue was that the Teams user is different from the Dynamics user. I used the Office365 Get User Profile, to get the email which I then matched to the Dynamics record.

View solution in original post

@mrpowergage 

Glad to help. Also thanx for posting a reply with the details to solve the issue! You will see I already marked it as Solution, this way other community member facing the same problem in the future can find the way to proceed faster

You guys make this community great!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (2,220)